danchirillo
Contributor
Contributor

Parse Exception in ESXi 6.5 Web Client Blocking Deployment of Image using .ova File

I've hit a brick wall and am wondering if this is a known issue with a known solution.

I've been trying to deploy an .ova file to an ESXi server.  I'm using the free license, so there's no VCenter.

The issue is that no matter which browser/operating system I use to try to deploy, the import wizard throws a parsing exception at Step 6

step3.jpg

   Already things look odd:

Step 4.jpg

  Look at the Deployment type dropdown:

Step 5.jpg

Step 6.jpg

The details of the exception:

Cause: Error: [$parse:syntaz] http://errors.angularjs.org/1.3.20/$parse/syntax?p0=.1.&p1=is%20an%20unexpected%20token&p2=58&p3=wiz...

Version: 1.27.1

Build: 7909286

ESXi: 6.5.0

Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:65.0) Gecko/20100101 Firefox/65.0

Exception stack:

S/<@https://172.16.125.102/ui/scripts/main.js:318:20612

throwError@https://172.16.125.102/ui/scripts/main.js:321:18900

parse@https://172.16.125.102/ui/scripts/main.js:321:18184

Oe/this.$get</<@https://172.16.125.102/ui/scripts/main.js:320:9454

$watch@https://172.16.125.102/ui/scripts/main.js:320:14476

getPropertyFields/</<@https://172.16.125.102/ui/scripts/main.js:368:22404

r@https://172.16.125.102/ui/scripts/main.js:318:21018

getPropertyFields/<@https://172.16.125.102/ui/scripts/main.js:368:20271

r@https://172.16.125.102/ui/scripts/main.js:318:21124

getPropertyFields@https://172.16.125.102/ui/scripts/main.js:368:20028

@https://172.16.125.102/ui/scripts/main.js:368:23602

e@https://172.16.125.102/ui/scripts/main.js:319:3872

Fe/this.$get</</<@https://172.16.125.102/ui/scripts/main.js:319:23883

I/<@https://172.16.125.102/ui/scripts/main.js:319:15273

r@https://172.16.125.102/ui/scripts/main.js:318:21124

I@https://172.16.125.102/ui/scripts/main.js:319:15257

g@https://172.16.125.102/ui/scripts/main.js:319:11540

G/<@https://172.16.125.102/ui/scripts/main.js:319:11155

Q/<@https://172.16.125.102/ui/scripts/main.js:319:12029

h@https://172.16.125.102/ui/scripts/main.js:319:14061

link/<@https://172.16.125.102/ui/scripts/main.js:321:31965

$digest@https://172.16.125.102/ui/scripts/main.js:320:16343

$apply@https://172.16.125.102/ui/scripts/main.js:320:17773

l@https://172.16.125.102/ui/scripts/main.js:319:26637

F@https://172.16.125.102/ui/scripts/main.js:319:28783

wf/</C.onload@https://172.16.125.102/ui/scripts/main.js:319:29325

0 Kudos
3 Replies
daphnissov
Immortal
Immortal

First thing to try:  Upgrade your embedded host client and try again.

0 Kudos
danchirillo
Contributor
Contributor

Thanks for the idea.  I ended up working around the issue by using the OVF command line tool.

0 Kudos
daphnissov
Immortal
Immortal

Based on your version of the host client, though, you still need to upgrade to get other fixes.

0 Kudos