amgur
Contributor
Contributor

OVFtool VM export to OVF fails on ESXI 6.5 - Curl_perform error code 18 (Transferred a partial file)

Hi,

I have tried for several days now to export a VM from ESXI 6.5 server both by using OVFtool and from web browser.

The export fails at about 12% when using ovftool and i have attached the ovftool log.

For browser export it fails and the error message displayed is "Failed - Network error"

Any ideas for why the export fails?

2020-09-29T22:48:10.704+02:00 verbose OVFTool[06784] [Originator@6876 sub=Default] Initializing new curl session

2020-09-29T22:48:10.727+02:00 warning OVFTool[06784] [Originator@6876 sub=Default] No Proxy Certificate specified.

2020-09-29T22:48:10.727+02:00 verbose OVFTool[06784] [Originator@6876 sub=Default] WebRequest set basic http authorization, username : root

2020-09-29T22:48:10.803+02:00 verbose OVFTool[06784] [Originator@6876 sub=Default] Upload disk do convert

2020-09-29T22:48:10.818+02:00 verbose OVFTool[06784] [Originator@6876 sub=Default] Opening disk target SERVER-disk1.vmdk

2020-09-29T22:58:09.720+02:00 verbose OVFTool[01620] [Originator@6876 sub=Default] Keeping VI session alive

2020-09-29T22:58:10.445+02:00 verbose OVFTool[03972] [Originator@6876 sub=Default] Keeping VI session alive

2020-09-29T23:03:14.343+02:00 verbose OVFTool[13268] [Originator@6876 sub=HttpConnectionPool-000000] [RemoveConnection] Connection removed; cnx: <SSL(<io_obj p:0x000001b134b6d348, h:-1, <TCP '192.168.254.6 : 54801'>, <TCP '192.168.1.80 : 443'> FD Closed>)>; pooled: 5

2020-09-29T23:03:14.344+02:00 verbose OVFTool[01696] [Originator@6876 sub=HttpConnectionPool-000000] [RemoveConnection] Connection removed; cnx: <SSL(<io_obj p:0x000001b134b6e9d8, h:-1, <TCP '192.168.254.6 : 54799'>, <TCP '192.168.1.80 : 443'> FD Closed>)>; pooled: 4

2020-09-29T23:03:14.344+02:00 verbose OVFTool[24172] [Originator@6876 sub=HttpConnectionPool-000000] [RemoveConnection] Connection removed; cnx: <SSL(<io_obj p:0x000001b134b6e188, h:-1, <TCP '192.168.254.6 : 54796'>, <TCP '192.168.1.80 : 443'> FD Closed>)>; pooled: 3

2020-09-29T23:03:14.344+02:00 verbose OVFTool[01620] [Originator@6876 sub=HttpConnectionPool-000000] [RemoveConnection] Connection removed; cnx: <SSL(<io_obj p:0x000001b134b6eb08, h:-1, <TCP '192.168.254.6 : 54794'>, <TCP '192.168.1.80 : 443'> FD Closed>)>; pooled: 2

2020-09-29T23:08:09.730+02:00 verbose OVFTool[24164] [Originator@6876 sub=Default] Keeping VI session alive

2020-09-29T23:08:10.441+02:00 verbose OVFTool[13268] [Originator@6876 sub=Default] Keeping VI session alive

2020-09-29T23:18:09.730+02:00 verbose OVFTool[13268] [Originator@6876 sub=Default] Keeping VI session alive

2020-09-29T23:18:10.441+02:00 verbose OVFTool[21168] [Originator@6876 sub=Default] Keeping VI session alive

2020-09-29T23:28:09.765+02:00 verbose OVFTool[03972] [Originator@6876 sub=Default] Keeping VI session alive

2020-09-29T23:28:10.479+02:00 verbose OVFTool[24172] [Originator@6876 sub=Default] Keeping VI session alive

2020-09-29T23:38:09.778+02:00 verbose OVFTool[24248] [Originator@6876 sub=Default] Keeping VI session alive

2020-09-29T23:38:10.482+02:00 verbose OVFTool[27504] [Originator@6876 sub=Default] Keeping VI session alive

2020-09-29T23:40:19.550+02:00 verbose OVFTool[16464] [Originator@6876 sub=Default] Curl_perform error code 18 (Transferred a partial file)

2020-09-29T23:40:19.550+02:00 error OVFTool[06784] [Originator@6876 sub=Default] Error on read, error: -1

2020-09-29T23:40:19.550+02:00 verbose OVFTool[16464] [Originator@6876 sub=Default] Curl session torn down

2020-09-29T23:40:19.562+02:00 verbose OVFTool[08124] [Originator@6876 sub=Default] Exception thrown: class boost::exception_detail::clone_impl<struct boost::exception_detail::error_info_injector<class OvfToolException> >(Execution aborted)

2020-09-29T23:40:19.626+02:00 verbose OVFTool[08124] [Originator@6876 sub=Default] Backtrace:

--> [backtrace begin] product: VMware Workstation, version: e.x.p, build: build-15722219, tag: OVFTool, cpu: x86_64, os: windows, buildType: release

--> backtrace[00] vmacore.dll[0x00213F83]

--> backtrace[01] vmacore.dll[0x000648D0]

--> backtrace[02] vmacore.dll[0x0005F3C6]

--> backtrace[03] vmacore.dll[0x00025B46]

--> backtrace[04] ovftool.exe[0x000A8757]

--> backtrace[05] ovftool.exe[0x00084567]

--> backtrace[06] ovftool.exe[0x00054B76]

--> backtrace[07] ovftool.exe[0x00051709]

--> backtrace[08] ovftool.exe[0x000536B5]

--> backtrace[09] ovftool.exe[0x000551D4]

--> backtrace[10] ovftool.exe[0x000C1E3E]

--> backtrace[11] ovftool.exe[0x000C2821]

--> backtrace[12] ovftool.exe[0x00377FB8]

--> backtrace[13] KERNEL32.DLL[0x00014034]

--> backtrace[14] ntdll.dll[0x00073691]

--> [backtrace end]

2020-09-29T23:40:19.626+02:00 verbose OVFTool[08124] [Originator@6876 sub=Default] Erasing open readers for https://192.168.1.80:443/ha-nfc/52f1ed52-3ad2-1236-26ff-e63cda903ebc/SERVER-0.vmdk

2020-09-29T23:40:19.630+02:00 verbose OVFTool[08124] [Originator@6876 sub=Default] [Vi4Source] HttpNfcLease->Abort() is called.

2020-09-29T23:40:19.666+02:00 verbose OVFTool[08124] [Originator@6876 sub=Default] Closing writer. Locator: SERVER-disk1.vmdk (Written bytes: 17547994624)

2020-09-29T23:40:19.666+02:00 verbose OVFTool[08124] [Originator@6876 sub=Default] Openwriter: SERVER-disk1.vmdk

2020-09-29T23:40:19.666+02:00 verbose OVFTool[08124] [Originator@6876 sub=Default] Deleting file: c:\temp\SERVER\2909\SERVER\SERVER-disk1.vmdk

2020-09-29T23:40:24.085+02:00 verbose OVFTool[08124] [Originator@6876 sub=Default] Delete file result: true

2020-09-29T23:40:24.250+02:00 verbose OVFTool[08124] [Originator@6876 sub=Default] Destruction of ViSource

0 Kudos
3 Replies
nachogonzalez
Expert
Expert

Are you using vCenter?
Have you accepted ESXi host certificate?
Have you tried exporting the VM to ovf directly from the ESXi host?

0 Kudos
amgur
Contributor
Contributor

Hi,

Hi,

Thank's for the quick reply.

I'm not using vCenter, i tried to export directly from ESXi host web interface and with ovftool.

Not sure what you mean regarding certificate, can you explain that more?

0 Kudos
nachogonzalez
Expert
Expert

ESXi hosts have SSL certificates to use HTTPS traffic.
By default, those certificates are self-signed, which means computer's trust stores do not recognize them as "secure" (it's a security mechanism)
What you need to do is to "Accept" the certificate (the clearest example is firefox in which you make a security exception for that certificate)

I don't know if that explanation was useful.

0 Kudos