Contributor
Contributor

New Datastore Greyed out

Hi All,

Currently deploying a new vm host on a dell r740xd, have installed os to a raid 1 array working fine, also have built a 40tb raid10 on the server and am trying to provision datastores on this raid created the first 2 datastores just fine with 6tb on each and went to do the 3rd datastore but the option is greyed out.

have tried rescanning the hba, the device and also even given the server a full restart but its not letting me create new datastore, I can view the remaining free space which is 37tb but for some reason I cannot work out its not letting me add any more datastores just shows up no device has any free space.

server is running 6.5u2 esxi

any help appreciated

Lee

0 Kudos
3 Replies
Immortal
Immortal

Don't carve up a single extent (your 40 TB RAID-10) volume into multiple VMFS datastores. This just ends in trouble and increases complexity where you don't need it.

0 Kudos
Contributor
Contributor

ok thanks so you are saying one big 40tb datastore across the volume - idea was to seperate the datastores out from a logical perspective and for IO from a vmware queue depth perspective.

are you saying this cant be done?

0 Kudos
Immortal
Immortal

Even from a logical perspective, the bottleneck is still that controller. And, actually, unless you have that RAID-10 volume on a separate controller, your queue depth is being filled by the system volume as well (however slight I/O that may be, but still). What you're trying to do could possibly be done, but it's really not a good idea in your case and I don't recommend it.

0 Kudos