jbilbrey
Contributor
Contributor

Management network has no internet access

I have a feeling this is a super simple fix, but I can't seem to get it figured out. 

The management network when I ssh into my esxi 7 server has no internet access, I can't ping google. All the VM's are online with no issues connecting to the internet. 

When I issue the command: esxcli network ip interface ipv4 get

I get the following:

Name IPv4 Address IPv4 Netmask IPv4 Broadcast Address Type Gateway DHCP DNS
---- ------------ ------------- -------------- ------------ ------- --------
vmk0 192.168.2.10 255.255.255.0 192.168.2.255 STATIC 0.0.0.0 false

To me this just looks like the gateway needs to be updated to our gateway which is 192.168.2.254 but I can't seem to get any commands to update vmk0. 

Also I have set it with: esxcfg-route
VMkernel default gateway is 192.168.2.254

I have tried:
esxcli network ip interface ipv4 set –i vmk0 -t static –g 192.168.2.254 -I 192.168.2.10 -N 255.255.255.0

But this errors out:
Error: Unknown command or namespace network ip interface ipv4 set –i vmk0

Any advice would be appreciated.

 

 

 

Any advice would be appreciated.

0 Kudos
3 Replies
IRIX201110141
Champion
Champion

Within your ssh shell type "dcui" and than log into and configure the management networking by adjusting your address for the gateway.

 

Regards,
Joerg

Try with this:

esxcfg-route 192.168.2.254

 You can validate afterwards with:  esxcfg-route

 

-------------------------------------------------------------------
Triple VCIX (CMA-NV-DCV) | vExpert | MCSE | CCNA
jbilbrey
Contributor
Contributor

So somehow this was actually an issue on our firewall/router. One of our circuits had gone down and even though all the vm's and everything else swapped over to the other circuit the VM host for whatever reason never updated it's routing. After the other circuit came back online I was able to ping back out to google. 

0 Kudos