vmjoe
Enthusiast
Enthusiast

Issue with elxnet driver from HPE driver bundle and VUM

Hello

I have an issue with VMware Update Manager and would like to know how you would handle this situation:

HPE BL460c Gen8 hosts equipped with FlexFabric 10Gb 2-port 554M adapter running ESXi 6.0U3 (6.5U2 would be supported, but would not change the issue).

The card itself is supported by HPE with Gen8 blades:

https://support.hpe.com/hpsc/doc/public/display?docId=emr_na-c03215797

The 554M card is supported by VMware with driver elxnet version 11.1.183.654

https://www.vmware.com/resources/compatibility/detail.php?deviceCategory=io&productid=21423&vcl=true

BUT - if you use HPE Depot http://vibsdepot.hpe.com/index-drv.xml in Update Manager, it deploys hpe-driver-bundle-600.10.3.6 which contains a NEWER driver (elxnet 12.0.1115.0), which is not supported, and it crashes the hosts after some time (about 90 days in my experience). (Also previous bundles already contain the newer/unsupported elxnet driver.)

We encountered the problem described here ("UE detected!!"):

Lost network connectivity with Emulex Card [...]

https://kb.vmware.com/s/article/50106632?lang=en_US

I now manually downgraded the elxnet drivers and so far so good (although the problem previously occured only after about 90 days uptime). But now the hosts show up as "not up to date" and the entire HPE driver bundle is marked for installation. Since the bundle also contains "good" drivers like hpsa etc., I don't want to remove it entirely from the repository...

Is there a way to declare the older elxnet driver as the most current, or downgrade it in the bundle, or...?

Tags (3)
0 Kudos
1 Reply
mvaragnolo
Contributor
Contributor

Same here.

Keeping server updated using VUM (and HP's vibdepot) installs 12.0.1115.0 that causes PSOD.

VMware supported version is  11.1.183.654

0 Kudos