Jayar16
Contributor
Contributor

Install VMware Tools grayed out

I try to install vmware tools on ubuntu server. After using the command apt-get install update and upgrade, the Install VMware tools then grayed out. Can anyone help me find the root cause?

Tags (2)
9 Replies
vijayrana968
Virtuoso
Virtuoso

Generally this option will grey out if you have already initiated this and Tools image is mounted to guest VM. Go to VM settings and check if tools image is mounted. You might have initiated it previously.

0 Kudos
Zak18_07
Contributor
Contributor

Hello,

when you see this option grayed out that's means sometimes that you don't have a virtual Optique drive in your Vmware guest , so try to make one from menu VM->settings->ADD .
regards.

philip8
Contributor
Contributor

This works.

After adding a CD/DVD drive, "Install VMware Tools" is not grayed out anymore.

0 Kudos
shd01
Contributor
Contributor

I had a similar problem when installing a 64-bit Debian 9.x VM from a VirtualBox .ova file on VMware Workstation 14 Pro.

The problem was that the guest OS was set to "other" in Settings->Options->General

If I set the OS to Debian 9.x, VMware complained about the BusLogic SCSI driver being incompatible and would not launch the VM.

Finally following another post, I set the OS type to ubuntu (even though it's Debian).  Then it all worked; I was able to mount the vmware tools ISO and the "Install VMware Tools" menu option was available.  Then in the VM it just appeared as if a CD had been put in the drive.

NathanosBlightc
Commander
Commander

You can try to address following path of ISO files on the ESXi host :

/usr/lib/vmware/isoimages/linux.iso

or

/vmfs/volumes/vsanDatastore/vmtools/linux.iso

And then install the VMware Tools on guest OS again.

Please mark my comment as the Correct Answer if this solution resolved your problem
Wilmerwilkins
Contributor
Contributor

This worked for me too after a Fusion upgrade to 11:5 using a Windows 10 machine.

chathuo2
Enthusiast
Enthusiast

Okay so on mac I was trying to create a win 7 vm machine using vmware fusion on MacOS obviously. 

I had the same issue and what I did was I disabled cd/dvd  and restarted the machine, this re-enabled "install vmware tools".

 

How to disable

Open the specific vm screen > go into the  virtual machine drop down > settings >  then under  "Removable Devices" click on CD/DVD (SATA) >  Uncheck  "Connect CD/DVD drive".

 

This should re-enable  the   "install vmware tools". Thanks

0 Kudos
mranh1610
Contributor
Contributor

Sometimes it happens for no reason. I faced with it and my approach is that

Step 1: Shut down the VM.

Step 2: Remove the CD/DVD from the Virtual Machine.

Step 3: Start the VM

Step 4: After VM launched, go to Settings --> then Re-Add the CD/DVD. Right after that, a VM Installation tool pop-up will appear.

marcio_passos
Contributor
Contributor

Hi,

This works for me, but to windows 10

/usr/lib/vmware/isoimages/windows.iso

Thanks!

0 Kudos