DariuszNowara
Contributor
Contributor

Impossible to activate hyperthreading on ESXi 6.5 hosts

Jump to solution

Hi experts,

    I have a following riddle. I need to enable Ht on all the hosts in my environment. It is enabled on the HP servers itself (verified in the BIOS settings and there is a message during the boot that says it is enabled). the VMkernel.Boot.hyperthreading advanced property is set to $True. Whenever I go to the Settings -> Hardware -> Processors it says HT: Disabled. I set it to Enabled (there is a message next to it saying, that "Changes will not take effect until the host is restarted") and click OK. there us a task showing up at the bottom named "Enable Hyperthreading" which completes successfully and nothing changes - it remains "Disabled" and in the summary tab "Inactive". The reboot of the host doesn't change anything in this respect. Any clues here? Where to look for any related logs? Thank you in advnce for help!

0 Kudos
1 Solution

Accepted Solutions
DariuszNowara
Contributor
Contributor

Gents,

    It is HPE DL380 Gen 10. As mentioned it does have the HT enabled, which can be checked in the BIOS. In the end I found a solution after a lot of digging - disabling the VMKernel.Boot.hyperthreadingMitigation advanced option made it possible to tick the box. It is a little surprising to me as from the description of the setting it does not switch off the HT for good but only restricts it's use in a certain way

View solution in original post

3 Replies
rajen450m
Hot Shot
Hot Shot

Hi DariuszNowara

Please update the firmware of the hosts and try, we had a similar issue, resolved after updating firmware.

Regards,

Raj M Please mark helpful or correct if my answer resolved your issue. Visit www.hypervmwarecloud.com for my blog posts, step-by-step procedures etc.,
0 Kudos
bluefirestorm
Champion
Champion

Perhaps simplest explanation is that the CPU that is installed does not have Hyperthreading.

What is the CPU inside the server?

Not all Intel Xeon CPUs have hyperthreading. This is a list of Intel Xeon that does not have hyperthreading.

https://ark.intel.com/Search/FeatureFilter?productType=processors&HyperThreading=false&FamilyText=In...

0 Kudos
DariuszNowara
Contributor
Contributor

Gents,

    It is HPE DL380 Gen 10. As mentioned it does have the HT enabled, which can be checked in the BIOS. In the end I found a solution after a lot of digging - disabling the VMKernel.Boot.hyperthreadingMitigation advanced option made it possible to tick the box. It is a little surprising to me as from the description of the setting it does not switch off the HT for good but only restricts it's use in a certain way