ctufindgood
Contributor
Contributor

Import-Module VMware.PowerCLI failed

Jump to solution

Hi,

I am using VMware vSphere PowerCLI 5.5 to perform an integration with vRops.

However, when I tried to run "Import-Module VMware.PowerCLI" I am getting the following error:

Import-Module : Method invocation failed because [VMware.VimAutomation.Sdk.Impl.V1.CoreServiceImpl] does not contain a

method named 'OnImportModule'.

pastedImage_2.png

I have tried the same thing with VMware vSphere PowerCLI 6.5 without any problem.

Any feedback is greatly appreciated.

Best Regards,

Daniel Lee

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
GayathriS
Expert
Expert

Hi

I see that Power CLI 5.5 is not supported with recent vrops version ,

see below for supported powercli versions with vrops :

pastedImage_0.png

VMware Product Interoperability Matrices

Please consider marking this answer as "correct" or "helpful" if you think your questions have been answered.

View solution in original post

0 Kudos
1 Reply
GayathriS
Expert
Expert

Hi

I see that Power CLI 5.5 is not supported with recent vrops version ,

see below for supported powercli versions with vrops :

pastedImage_0.png

VMware Product Interoperability Matrices

Please consider marking this answer as "correct" or "helpful" if you think your questions have been answered.

0 Kudos