frankygmail
Contributor
Contributor

How to move the VM to anther vSwitch in ESXi6.7?

Jump to solution

Hello, I am trying to add usb-nic to ESXi6.7 host which sits at Dell desktop. The usb-nic is plugged into the PC as we can see red arrow in the below screenshot. Now windows 10 (w10) is installed in the ESXi host as we can see it in red circle label in the below picture, but the w10 is in another vSwitch.  I want to move the w10 to the vSwitch indicated by the red arrow. Anyone can help for this? Thank you 

 

frankygmail_0-1610390443279.png

0 Kudos
1 Solution

Accepted Solutions
scott28tt
VMware Employee
VMware Employee

@frankygmail 

You’ve done exactly the same as in your initial post.

Stop adding a VMkernel port to the port group on the vSwitch if you want to use that port group for VMs - a single port group cannot be used for both VMs and the VMkernel.

View solution in original post

0 Kudos
12 Replies
a_p_
Leadership
Leadership

VMs can only be attached to Virtual Machine port groups.
Create a new virtual machine port group on the vSwitch, and you will be able to connect your VM to it.

André

0 Kudos
nachogonzalez
Expert
Expert

Find the VM in vCenter inventory (vSphere Web Client) --> Right Click --> Edit settings --> Under Network Adapter # you have a drop down with the actual portgroup the VM is connected. Select another Portgroup --> CLick Ok. 

0 Kudos
frankygmail
Contributor
Contributor

Why i cannot see your replies? 

 

 

frankygmail_1-1610397636592.png

 

 

 

0 Kudos
scott28tt
VMware Employee
VMware Employee

@frankygmail 

Moderator: Moved to vSphere Discussions, not specific to any vCenter branded product.

0 Kudos
scott28tt
VMware Employee
VMware Employee

@frankygmail 

You need to create a VM Port Group on that vSwitch, then edit the NIC of the VM to connect to that VM Port Group.

 

0 Kudos
frankygmail
Contributor
Contributor

Hi Friends

I can see there are "5 replies" for my post, but I cannot see the contents. Now you can see what I can see in the below screenshot. What is wrong with it. I have the issue for weeks, but no one can resolved it. Anyone can help to contact the administrator? I love your guys comments very much. I hope to see your comments asap. Thank you very much!

 

frankygmail_0-1610406490915.png

 

0 Kudos
frankygmail
Contributor
Contributor

I even cannot see my post except the first one

0 Kudos
scott28tt
VMware Employee
VMware Employee

@jennivmtn 

Any idea why the user cannot see any replies?

 

0 Kudos
frankygmail
Contributor
Contributor

Thank you very much for your help. Now I can see your post and comments

Based on your suggestions, I created port-group, and associated with physical adapter(usb-nic) and PortGroup. but when I try to add the port-group, I cannot find it. Please see the below screenshots:

Any suggestions?

 

Capture1.PNG

 

Capture.PNG

0 Kudos
frankygmail
Contributor
Contributor

d

0 Kudos
scott28tt
VMware Employee
VMware Employee

@frankygmail 

You’ve done exactly the same as in your initial post.

Stop adding a VMkernel port to the port group on the vSwitch if you want to use that port group for VMs - a single port group cannot be used for both VMs and the VMkernel.

View solution in original post

0 Kudos
frankygmail
Contributor
Contributor

Thank you scott28tt!

I got it!

0 Kudos