as900w
Hot Shot
Hot Shot

How to add the number of vSphere HA heartbeat datastores for the ESXi host

Jump to solution

I have a cluster and enabled vSphere HA.

After enabled vSphere HA, have a warning:

The number of vSphere HA heartbeat datastores for this host is 0, which is less then required:2

1.PNG

I have a iSCSI Storage(Windows Server 2012)

And add storage to ESXi hosts

2.PNG

What should I do?

0 Kudos
1 Solution

Accepted Solutions
diegodco31
Leadership
Leadership

You need to add a second datastore.

Then right click each of the ‘hosts’ and select ‘Reconfigure for HA’.

Diego Oliveira LinkedIn: http://www.linkedin.com/in/dcodiego

View solution in original post

5 Replies
diegodco31
Leadership
Leadership

Check it link:

vSphere - 'The Number of HA Heartbeat Datastores for this host is 0' | PeteNetLive

pastedImage_0.png

Please consider marking this answer "correct" or "helpful" if you think your question have been answered correctly.

Diego Oliveira LinkedIn: http://www.linkedin.com/in/dcodiego
diegodco31
Leadership
Leadership

HA datastore heartbeating comes into play if a HA cannot reach other hosts on the network. The secondary datastore provides additional resilience, and if you don't want to create a second datatsore, you may consider to disable the warning (see HA error: "The number of heartbeat datastores for host is 1, which is less than required: 2" (200473... )

Diego Oliveira LinkedIn: http://www.linkedin.com/in/dcodiego
as900w
Hot Shot
Hot Shot

I have seen this KB.

I want to solve the warning instead of ignoring it.

0 Kudos
diegodco31
Leadership
Leadership

You need to add a second datastore.

Then right click each of the ‘hosts’ and select ‘Reconfigure for HA’.

Diego Oliveira LinkedIn: http://www.linkedin.com/in/dcodiego
as900w
Hot Shot
Hot Shot

Thanks, I has been solve the warning.

add second datastore in Heartbeat Datastores

0 Kudos