VMware Cloud Community
ianmac28sco
Contributor
Contributor
Jump to solution

How do you set VM Type Portgroup using ESXi 6.7 Web Client

I have just installed ESXi on two new servers. I am using the web client to configure the systems.

I am trying to set up a private network on a vSwitch as so:

pastedImage_1.png

The 'Host Only' port group does not appear in the drop-down of the VM NIC configuration:-

pastedImage_2.png

Only the default 'VM Network' appears.

After a lot of Googling I realise that the portgroup could be configured as a 'Kernel' port group, which would mean it is only for Management traffic.

The question is: How do you configure the portgroup to be a 'VM' type using the ESXi 6.7 web client or using the esxcli?

The 'about' reports as:-

VMware ESXi™

1.25.1

9210161

6.7.0

9484548

Reply
0 Kudos
1 Solution

Accepted Solutions
daphnissov
Immortal
Immortal
Jump to solution

A vSwitch with a vmkernel port on it cannot take other port groups for virtual machines. You may need to create a dedicated vSwitch and only put virtual machine port groups on it.

View solution in original post

Reply
0 Kudos
4 Replies
daphnissov
Immortal
Immortal
Jump to solution

You would need to create a new port group. The default is for a virtual machine.

Also, I can't help but notice you've assigned a public IP address to an ESXi host which both has a PTR record on public DNS servers and responds to ICMP. Exposing ESXi is a terrible security idea and should absolutely be avoided. ESXi or vCenter are not intended to be exposed on the public Internet.

Reply
0 Kudos
ianmac28sco
Contributor
Contributor
Jump to solution

Hi daphnissov,

Thankyou for your quick response.

Creating a new portgroup does not give the option to select a type. See the screenshot:-

pastedImage_0.png

...and it seems to default to 'Kernel'. Also, when the port group is viewed, it doesn't indicate which type it is!

Is there a way to do this from the esxcli?

Re public internet: This system is a trial. I am setting it up before it goes on to a private network. I've set the firewall to restrict access to a couple of source addresses. Thanks for the info.

Ian

Reply
0 Kudos
daphnissov
Immortal
Immortal
Jump to solution

A vSwitch with a vmkernel port on it cannot take other port groups for virtual machines. You may need to create a dedicated vSwitch and only put virtual machine port groups on it.

Reply
0 Kudos
ianmac28sco
Contributor
Contributor
Jump to solution

Ok, so I have now figured it out. Thanks daphnissov.

A Portgroup is a Kernel type if it contains a VMNIC, and does not appear in the VM NIC list of Portgroups.

If it doesn't contain a VMNIC, it is a VM type, and does appear in the VM NIC list of Portgroups.

Simple when you know.

Reply
0 Kudos