thomaselser
Contributor
Contributor

Export from ESXi 7.0 to OVF, no Popup

Hi guys!

I have two ESXi servers (licensed with Essentials). 
I can succesfully export  a vm from server "A" to  a OVA  -  everytime I do that a popup apperas where I can choose the files to download.
(I am using ESXi Webinterface, not vCenter Server)

On Server "B" that popup never appears and nothing is happening (There is a task in the task  list saying "running", but that  is not doing anything).
(But id did work the day before, I successfully exported a vm from Server "B" before)

Any ideas how I get the popup to reappear on Server "B"? 
I am MS Edge Chrome, but also tried with Firefox. (There are no add blockers installed.)

Thanks in advance for your help
Tom

Labels (1)
0 Kudos
11 Replies
vbondzio
VMware Employee
VMware Employee

If the task is hanging it is unlikely to be browser related (still always try in incognito / without plugins just to be safe). What is the error when the task fails and how long does it take? If that isn't giving you more to go off, you might need to check the hostd logs on the host. Does this still happen after you restart host services, the whole host?

0 Kudos
thomaselser
Contributor
Contributor

The task   is running forever till I kill it ... 
I already restarted the hsot twice, same thing.  Trying three diffent VMs.
Copied one VM to host "A", there the export is working fine ...

It looks to me that the  host is waiting for input frum the popup to start the job.
Starting the export on host "A" immediately opens this popup where I need to confirm the files to export....

0 Kudos
vbondzio
VMware Employee
VMware Employee

There are a bunch of things you could do ... are there any errors in the console output in the browser (e.g. ctrl-shift-n) compared to the other one? Can you identify and grep for the task id in the hostd logs to confirm whether it is waiting for input? Does it work with OVF Tool https://code.vmware.com/web/tool/4.4.0/ovf ? Does it work to save files from the datastore? Can you export host logs (as a test, not for me to look at)?

I'm assuming the hosts are otherwise the same model / ESXi build etc.

0 Kudos
thomaselser
Contributor
Contributor

Export Log => OK

Copy files from and to datastore(s) => OK

Can you please help me out how to do this?:
"Can you identify and grep for the task id in the hostd logs to confirm whether it is waiting for input?"

Thanks for your time!
Tom

0 Kudos
vbondzio
VMware Employee
VMware Employee

I'd definitely test whether it works with the OVF Tool, this is to eliminate the actual function from something in the client / browser.

Does the task hang at the same percentage / progress the popup is supposed to happen (50%)?

I just did export on a VM and looked at the logs when I saw the pop-up, I used the date time (UTC!) I saw in the "Started" column for the grep:

[root@esxi02:~] egrep "^2021-04-05T09:47:42.*Task Created" /var/log/hostd.log
2021-04-05T09:47:42.110Z info hostd[1826207] [Originator@6876 sub=Vimsvc.TaskManager opID=esxui-2a6c-0a7d user=root] Task Created : haTask-12-vim.VirtualMachine.exportVm-1221
2021-04-05T09:47:42.110Z info hostd[1826193] [Originator@6876 sub=Vimsvc.TaskManager opID=esxui-2a6c-0a7d user=root] Task Created : haTask-12-vim.VirtualMachine.exportVm-1222
2021-04-05T09:47:42.307Z info hostd[1826202] [Originator@6876 sub=Vimsvc.TaskManager opID=esxui-d8a7-0a88 user=root] Task Created : haTask--vim.OvfManager.createDescriptor-1223
[root@esxi02:~] egrep "2a6c-0a7d|d8a7-0a88" /var/log/hostd.log
2021-04-05T09:47:42.110Z info hostd[1826207] [Originator@6876 sub=Vimsvc.TaskManager opID=esxui-2a6c-0a7d user=root] Task Created : haTask-12-vim.VirtualMachine.exportVm-1221
2021-04-05T09:47:42.110Z info hostd[1826193] [Originator@6876 sub=Vimsvc.TaskManager opID=esxui-2a6c-0a7d user=root] Task Created : haTask-12-vim.VirtualMachine.exportVm-1222
2021-04-05T09:47:42.111Z info hostd[1826193] [Originator@6876 sub=Vmsvc.vm:/vmfs/volumes/5c5466b8-1f85fd90-7859-109836041da8/0010-VMware-Appliance-FaH_1.0.1/0010-VMware-Appliance-FaH_1.0.1.vmx opID=esxui-2a6c-0a7d user=root] State Transition (VM_STATE_OFF -> VM_STATE_EXPORTING)
2021-04-05T09:47:42.118Z info hostd[1826193] [Originator@6876 sub=Vimsvc.TaskManager opID=esxui-2a6c-0a7d user=root] Task Completed : haTask-12-vim.VirtualMachine.exportVm-1221 Status success
2021-04-05T09:47:42.307Z info hostd[1826202] [Originator@6876 sub=Vimsvc.TaskManager opID=esxui-d8a7-0a88 user=root] Task Created : haTask--vim.OvfManager.createDescriptor-1223
2021-04-05T09:47:42.309Z info hostd[1826196] [Originator@6876 sub=Default opID=esxui-d8a7-0a88 user=root] [OvfProducer::SetDiskStorageGroup] disk key:2000
2021-04-05T09:47:42.309Z info hostd[1826196] [Originator@6876 sub=Default opID=esxui-d8a7-0a88 user=root] [OvfProducer::SetDiskStorageGroup] Device key is not present
2021-04-05T09:47:42.309Z info hostd[1826196] [Originator@6876 sub=Default opID=esxui-d8a7-0a88 user=root] [OvfProducer::AddVMStroageSection] No storage profiles
2021-04-05T09:47:42.311Z info hostd[1826196] [Originator@6876 sub=Vimsvc.TaskManager opID=esxui-d8a7-0a88 user=root] Task Completed : haTask--vim.OvfManager.createDescriptor-1223 Status success

You might want to tail -f /var/log/hostd.log while you try to reproduce.

0 Kudos
thomaselser
Contributor
Contributor

No, no percentage. It just sits there and says "running".

It won't let me download the OVF Tool with my account credentials, must ask the company to download it with the company credentials ...
I will get back to you as soon as I have  the tool to test.

Thanks again for your help, very much appreciated

0 Kudos
vbondzio
VMware Employee
VMware Employee

Just create your own (free) account, most downloads aren't linked to any product ownership.

0 Kudos
saint_iago
Contributor
Contributor

Hello, I know this is an older thread but hoping I could get some assistance. I am experiencing the same issue as described above. Currently trying to export some VMs on a host. I was able to export all the other VMs however one VM (lets call it VM A) is showing the same behavior. When right-clicking and then selecting "Export" on VM A, it does not pop up with a prompt to select which files or choose a network location. It simply creates a task which shows the "Result" column as full/to the end and the "Completed" column just says "Running..." with no percentage. When I've tried to run that export in the past and let is run it does not fail out. I've waited 2+ days and have just manually canceled it. I've tried from various devices and browsers. Any good troubleshooting steps to follow? or did you find a resolution to your issue?

0 Kudos
dkaluz
Contributor
Contributor

I had a single VM showing the same behavior. It turned out that it was because the VM had some snapshot running. Deleting all snapshots and disk consolidation resolved the issue for me. Also try checking if you have a ISO mounted to the VM.

0 Kudos
Klaus_Heubisch
Contributor
Contributor

I had a CD configured but not connected. The CD was bound to a file not to a physivcal file.

I'm not sure if the bound file existed.

After removing the connection the export worked well.

0 Kudos
virtume
VMware Employee
VMware Employee

No VMs from Host B is showing Popup when you export ? 

0 Kudos