Tony4688
Contributor
Contributor

Esxi 7.0.2 (HPE Customized image) with PSOD issue

I used vCenter to build vSphere cluster included 12 host, all host were installed Esxi 7.0.2 (HPE Customized image), then i built vSAN on this cluster.

All hosts worked properly before i created new VMs in cluster. After i created about 50 VMs in cluster, one of 12 host had PSOD as the below image:

I tried to solve this PSOD based on this article https://kb.vmware.com/s/article/83376 but the PSOD still occurs.

Does anyone have solution to solve this issue? 

Pls help me soon, thanks so much!

Labels (2)
Tags (2)
0 Kudos
8 Replies
fabio1975
Expert
Expert

Ciao 

There is no error image.
Of the indicated KB have you tried the workaround or the upgrade to 7.0 u2c?

 

Tony4688
Contributor
Contributor

Hi,

I inserted image into post but it was not showed, i just attach image again.

I checked system information in iLO Management GUI and see everything is OK and Redundant. The failed host has the same hardwares as normal hosts in this cluster. The failed host does not have any alerts too.

Do you want to see more logs of failed host to investigate the issue?

Many thanks!

0 Kudos
fabio1975
Expert
Expert

Ciao 

On which HPE server model are you experiencing the error?

 

Tony4688
Contributor
Contributor

Hi,

All hosts in cluster are HPE ProLiant DL380 Gen10, Intel(R) Xeon(R) Gold 6258R CPU @ 2.70GHz

Thanks!

0 Kudos
Tony4688
Contributor
Contributor

I installed the latest image VMware-ESXi-7.0.2-17867351-HPE-702.0.0.10.7.0.52-May2021 for all hosts in cluster.

Thanks!

0 Kudos
Tony4688
Contributor
Contributor

I have more logs for this issue from /var/log/vua.log as below:

34:2021-09-08T03:07:45.037Z info vua[4038045] [Originator@6876 sub=Default] Not empty libdir = /usr/share/vua
35:2021-09-08T03:07:45.037Z info vua[4038053] [Originator@6876 sub=ThreadPool] Entering fair thread loop
36:2021-09-08T03:07:45.037Z info vua[4038047] [Originator@6876 sub=ThreadPool] Spawning additional worker - allocated: 5, idle: 0
37:2021-09-08T03:07:45.037Z info vua[4038045] [Originator@6876 sub=Libs] Could not expand environment variable HOME.
38:2021-09-08T03:07:45.037Z info vua[4038045] [Originator@6876 sub=Libs] Could not expand environment variable HOME.
39:2021-09-08T03:07:45.037Z info vua[4038045] [Originator@6876 sub=Libs] DictionaryLoad: Cannot open file "/usr/lib/vmware/config": No such file or directory.
40:2021-09-08T03:07:45.037Z info vua[4038045] [Originator@6876 sub=Libs] DictionaryLoad: Cannot open file "~/.vmware/config": No such file or directory.
41:2021-09-08T03:07:45.037Z info vua[4038045] [Originator@6876 sub=Libs] DictionaryLoad: Cannot open file "~/.vmware/preferences": No such file or directory.
42:2021-09-08T03:07:45.037Z info vua[4038054] [Originator@6876 sub=ThreadPool] Entering worker thread loop

Tags (1)
0 Kudos
fabio1975
Expert
Expert

Ciao 

I think the PSOD error and the log reports are two different anomalies.


For PSOD I recommend you update to the latest released version of the ESXi (7.0u2c)

While for the logs it seems interesting to me this post:

https://communities.vmware.com/t5/ESXi-Discussions/Error-usr-lib-vmware-config-No-such-file-in-var-l...

Tony4688
Contributor
Contributor

I already solve this issue after upgrade Esxi, thanks so much!

0 Kudos