diogocrearj
Contributor
Contributor

Esxi 6.7: This VM is attached to a network portgroup that doesn't exist. Edit this VM and attach it to a different network

All the new vm that I create is using E1000e adapter and I can't change it in Edit Settgins.

I already tried to change with vm turned off but operations are not saved. How can I change this E1000e adapter to the previous, E1000 or VMXNET3?

E1000e-adapter.jpg

I already in Chrome, IE and as administrator account in my Windows workstation. And also with VMware Workstation Pro 15, but nothing happens.

0 Kudos
11 Replies
StephenMoll
Expert
Expert

The VM is powered off right?

0 Kudos
diogocrearj
Contributor
Contributor

yes, tested poweroff

0 Kudos
continuum
Immortal
Immortal

> This VM is attached to a network portgroup that doesn't exist. Edit this VM and attach it to a different network

If that is the reason you think you need to change anything then you need to adjust the parameter
ethernet0.networkName =
Not the parameter
ethernet0.virtualDev =
which appears to be what you are trying now.

Do you need support with a recovery problem ? - send a message via skype "sanbarrow"
0 Kudos
diogocrearj
Contributor
Contributor

Right, but where do I set this up? I need to access the esxi by ssh termimal? And which file?

0 Kudos
StephenMoll
Expert
Expert

It's the drop-down next to "Network Adapter 1", which currently shows as empty in your screenshot.

This is where you select the port group on your vSwitch to attach the vNIC to.

0 Kudos
diogocrearj
Contributor
Contributor

Because it is, there is no option in this field.

And the error I get when creating a new vm is just about the network.

See, I tried to create a new vm, the network comes with no configuration and when I try to add, it shows this error.

vmware6.7_errornetworkadding.JPG

Details:

Cause: TypeError: Cannot read property 'value' of undefined

Version: 1.25.1

Build: 9210161

ESXi: 6.7.0

Browser: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.119 Safari/537.36

Exception stack:

TypeError: Cannot read property 'value' of undefined

  at n.$scope.addNetwork (https://10.10.1.10/ui/scripts/main.js:373:1358)

  at onClick (https://10.10.1.10/ui/scripts/main.js:370:3761)

  at n.scope.clickAction (https://10.10.1.10/ui/scripts/main.js:461:24391)

  at https://10.10.1.10/ui/scripts/main.js:321:23160

  at https://10.10.1.10/ui/scripts/main.js:430:14519

  at n.$eval (https://10.10.1.10/ui/scripts/main.js:320:17497)

  at n.$apply (https://10.10.1.10/ui/scripts/main.js:320:17723)

  at HTMLAnchorElement.<anonymous> (https://10.10.1.10/ui/scripts/main.js:430:14501)

  at HTMLAnchorElement.dispatch (https://10.10.1.10/ui/scripts/main.js:317:14464)

  at HTMLAnchorElement.r.handle (https://10.10.1.10/ui/scripts/main.js:317:11251)

0 Kudos
diogocrearj
Contributor
Contributor

The weird thing is that the 10 old vms before the expiration of the full license are running with the disconnected VM Network status. I changed the license for free, already.

See

vmware6.7-generalsettings_vmnetworkdown.JPG

Networking:

vmware6.7-generalsettings_vmnetworkdown-2.JPG

vmware6.7-vmnetwork.JPGESXi​ @StephenMol

0 Kudos
diogocrearj
Contributor
Contributor

Hi, can you help me where I set it?

0 Kudos
continuum
Immortal
Immortal

Just edit the vmx-file directly if the web interface does not offer that option.

Do you need support with a recovery problem ? - send a message via skype "sanbarrow"
0 Kudos
a_p_
Leadership
Leadership

It looks like something went wrong here with the configuration, tht needs to be fixed.

The port group named "VM Network", which by default is a virtual machine port group, shows up as a VMkernel port group!? I wonder how the other port groups' details look like!?

What you may try to do at this point is to create a new "Virtual Machine" port group with a name like e.g. "LAN" to see whether you can use this for the VMs.

André

0 Kudos
Himadri
Contributor
Contributor

1. Shutdown VM

2. Download VMX file

3. Edit vmx file

4. Change the adapter.

0 Kudos