Dan98133
Contributor
Contributor

Enable copy paste globally (ESXi and VCSA v6.7)?

Jump to solution

On each host, modified /etc/vmware/config

added

vmx.fullpath = "/bin/vmx"

isolation.tools.copy.disable="FALSE"

isolation.tools.paste.disable="FALSE"

Updated VMWare tools on each VM.

Removed VM from inventory and re-added.

Copy and paste still does not work between the VMware Remote Console.  Please advise.

If anyone else is not having and issue with this using v6.7, please reply.

0 Kudos
1 Solution

Accepted Solutions
Dan98133
Contributor
Contributor

Resolved.  To close the loop on this:

The actions taken and outline here and other places are correct.

I did not have to reboot my host servers, however, the edit did not take effect immediately.

Simply closing and re-opening the VMRC sessions was not effective.

Copy and paste between VMRC is now working after a 24+ hour delay after making the config file edits.

If there is a manual way to effect the config file edits sooner without rebooting the host servers, this will probably be useful for others.  Thanks!

---------------------------------------------------------------------------------------------------------

Was it helpful? Let us know by completing this short survey here.

View solution in original post

0 Kudos
5 Replies
Alex_Romeo
Leadership
Leadership

Hi,

all three parameters must be set:

VMware Knowledge Base

Resolution

To resolve this issue,
  1. Install or upgrade the VMware tools for the Windows/Linux virtual machine(VM). For more information see Installing and upgrading VMware Tools in vSphere.
  2. Enable the Copy&Paste for the Windows/Linux virtual machine.
    1. Right-click the virtual machine and click Edit Settings.
    2. Click VM Options, and click Edit Configuration.
    3. Ensure that the following values are in the Name and Value columns or click Add Row to add them.
  • Name Recommended Value
isolation.tools.copy.disable FALSE
isolation.tools.paste.disable FALSE
isolation.tools.setGUIOptions.enable TRUE

  1. ​These options override any settings made in the guest operating system’s VMware Tools control panel. Click OK.
  2. If the changes are made to the configuration parameters, restart the virtual machine.

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Enable content Copy/Paste between VMRC

  1. isolation.tools.copy.disable FALSE
    isolation.tools.paste.disable FALSE
    isolation.tools.setGUIOptions.enable TRUE

Disable content Copy/Paste between VMRC

  1. isolation.tools.copy.disable TRUE
    isolation.tools.paste.disable TRUE
    isolation.tools.setGUIOptions.enable FALSE

Alessandro Romeo

Blog: https://www.aleadmin.it/
0 Kudos
Dan98133
Contributor
Contributor

Thank you Alessandro.  However, this does not seem to answer how to set the option globally.  The point is to not have to modify the settings for each VM.  If a global setting is no longer an option, it will help me and other users if this is explicitly stated.  If it is an option, I'm looking for support on how to enable it for ESXi and VCSA v6.7.  Thank you and kind regards, Dan

0 Kudos
Alex_Romeo
Leadership
Leadership

Hi,

I did exactly what is written here for all VMs

Enable copy and paste on VMware ESXi VMs – 4sysops

-------------------------------------------------------------------------------

Enable copy and paste for all VMs ^

You'll need to use a Secure Shell (SSH) client for this, and you'll have to enable SSH on the host. A free SSH client for Windows called PuTTY is well known. There are plenty of others, and you can also install one as an extension in your web browser.

Then simply log in to the ESX/ESXi host as a root user.

Open the /etc/vmware/config file using the vi editor. Navigate first to the right directory (cd /etc/vmware), then type "i" to switch to insert mode, and then enter this command:

1

vi config

Note: You should make a backup of the /etc/vmware/config file. You can do this with the command below after you go into the /etc/vmware folder:

1

cp config config_old

This saves the original file as "config_old."

Once you have the backup of the original file, you can add these entries to the file:

1

vmx.fullpath = "/bin/vmx"isolation.tools.copy.disable="FALSE"isolation.tools.paste.disable="FALSE"

Edit the config file

Edit the config file

Save and close the file. We're done.

For the ESXi setting, you'll need to reboot the ESXi host for the values to take effect.

----------------------------------------------------------------------

These are the same changes reported by you.
In the end I restarted the host and it worked.
The reboot is necessary, did you restart the hosts ??

Alessandro Romeo

Blog: https://www.aleadmin.it/
0 Kudos
Dan98133
Contributor
Contributor

Resolved.  To close the loop on this:

The actions taken and outline here and other places are correct.

I did not have to reboot my host servers, however, the edit did not take effect immediately.

Simply closing and re-opening the VMRC sessions was not effective.

Copy and paste between VMRC is now working after a 24+ hour delay after making the config file edits.

If there is a manual way to effect the config file edits sooner without rebooting the host servers, this will probably be useful for others.  Thanks!

---------------------------------------------------------------------------------------------------------

Was it helpful? Let us know by completing this short survey here.

0 Kudos
Grime121
Contributor
Contributor

You said to add the following as a single line to the etc/vmware/config file, but I think it is supposed to be three separate lines, isn't it?

 

vmx.fullpath = "/bin/vmx"isolation.tools.copy.disable="FALSE"isolation.tools.paste.disable="FALSE"

 

Should be....

 

vmx.fullpath = "/bin/vmx"

isolation.tools.copy.disable="FALSE"

isolation.tools.paste.disable="FALSE"

 

It is also worth noting that copy/paste between your computer and the VM only works when using the full-blown VM Remote Console. It does not work when using the Web Console. Also, copying/pasting files does not work. You can only copy/paste TEXT between your computer and the VM (and vice versa). That caused me some issues at first, when I was testing... I was trying to copy/paste a text file, rather than just plain text. I couldn't figure out why it wasn't working, until I tried copying/pasting plain text instead, which did work.