VMware Cloud Community
Tombie
Contributor
Contributor
Jump to solution

ESXi 6.5 management on low bandwidth connection

Hi all,

I manage an ESXi server on a remote location.

This location is in the middle of nowhere. The bandwidth to the location is 256KB up and 256KB down.

Unfortunutually this is the maximum speed we can get on the location.

In the past we connected with the old C# client to ESXi.

After an update from ESXi 5.5 to 6.5 this is not possible anymore.

We use the HTML5 client now.

The old C# client took less bandwidth than the new HTML5 client.

When I connect to the server, I have to wait 2 minutes before I see the Username and Password fields.

The browser is downloading 8 MB data for this page.

The biggest pain is main.js with 4.6 MB (Took 1,6 Minutes to load, see attachment)

Does anybody know how I can speed up the login and management?

Are there settings to cache the biggest files?

Is ESXi 6.7 more bandwidth friendly

And don't say I have to upgrade the connection Smiley Happy

Thanks!

Reply
0 Kudos
1 Solution

Accepted Solutions
Tombie
Contributor
Contributor
Jump to solution

Hi Dave,

I've created an reversed proxy with Apache.

With mod_cache enabled I've managed to decrease the login time from more than 2 minutes to < 2 seconds!

I'm only caching the static content in the /ui directory.

It's an very bad workaround, but it is working!

Thanks for the help to point me to experimenting with the caching!

View solution in original post

Reply
0 Kudos
3 Replies
Dave_the_Wave
Hot Shot
Hot Shot
Jump to solution

I would experiment with all web browsers and cache settings such that you may eventually find one where you can just leave it opened and always logged in.

You are right, I do not know why the server has to keep resending the client on each login, you'd think local cache would take care of that.

Tombie
Contributor
Contributor
Jump to solution

Hi Dave,

Thanks for the answer. I've tried IE, Edge, Chrome and Firefox.

Chrome was the least slow. But still more than 2 minutes.

Unfortunutually VMware is not sending any HTTP caching headers.

So the browser is not caching anything.

Now I have the browser always opened during the installation of the VMs. That works too. But I cannot leave it open for the next couple years Smiley Happy

Reply
0 Kudos
Tombie
Contributor
Contributor
Jump to solution

Hi Dave,

I've created an reversed proxy with Apache.

With mod_cache enabled I've managed to decrease the login time from more than 2 minutes to < 2 seconds!

I'm only caching the static content in the /ui directory.

It's an very bad workaround, but it is working!

Thanks for the help to point me to experimenting with the caching!

Reply
0 Kudos