MasterWayZ
Enthusiast
Enthusiast

Cluster is not compatible for Workload Management

I've been attempting to deploy a lab with Workload Management.

I get the following error:

|---------|----------|----------------------------------------------------------------------------------------|

|cluster  |compatible|incompatibility_reasons                                                                 |

|---------|----------|----------------------------------------------------------------------------------------|

|domain-c8|False     |Failed to list all distributed switches in vCenter 6dcc5e60-275c-41f6-bb62-f2c67ca1ea8d.|

|         |          |Cluster domain-c8 is missing compatible NSX-T VDS.                                      |

|---------|----------|----------------------------------------------------------------------------------------|

wcp log file:

2020-07-02T20:24:58.753Z debug wcp [opID=vapi] Sending response with output {"output":[{"STRUCTURE":{"com.vmware.vcenter.namespace_management.cluster_compatibility.summary":{"cluster":"domain-c8","compatible":false,"incompatibility_reasons":[{"STRUCTURE":{"com.vmware.vapi.std.localizable_message":{"args":["6dcc5e60-275c-41f6-bb62-f2c67ca1ea8d"],"default_message":"Failed to list all distributed switches in vCenter 6dcc5e60-275c-41f6-bb62-f2c67ca1ea8d.","id":"vcenter.wcp.nsx.list.dvs.error","localized":{"OPTIONAL":null},"params":{"OPTIONAL":null}}}},{"STRUCTURE":{"com.vmware.vapi.std.localizable_message":{"args":["domain-c8"],"default_message":"Cluster domain-c8 is missing compatible NSX-T VDS.","id":"vcenter.wcp.ncp.cluster.incompatible","localized":{"OPTIONAL":null},"params":{"OPTIONAL":null}}}}]}}}]}

This is odd, since I do have a NSX-T VDS deployed in the cluster.

vExpert 2020
Tags (1)
0 Kudos
2 Replies
Alex_Romeo
Leadership
Leadership

Hi,

Troubleshoot Workload Management Enablement Cluster Compatibility Errors

ARomeo

Blog: https://www.aleadmin.it/
0 Kudos
MasterWayZ
Enthusiast
Enthusiast

That's what I already did, though no luck and not all commands seem to work.

clustercompatibility works and gives the error above, but others do not, giving this:

Server error: com.vmware.vapi.std.errors.Unauthorized

Error message:

    Unable to authorize user

Which is very strange, seen that I use the correct username and password and that first command does give an output.

vExpert 2020
0 Kudos