Contributor
Contributor

Chrome "Remember this action" checkbox removed for SSO and Remote Console launch in vSphere

Jump to solution

A recent update to Chrome 77 intentionally removed the "remember this action" checkbox when launching applications through the browser. There are a ton of Google forum posts about how this has broken various applications, but for vSphere, it's mostly just a nuisance to have an extra button click required to log in and open a remote console. Here is the workaround they've given us:

https://support.google.com/chrome/thread/14194567?msgid=15347344

Basically, modifying a Chrome settings file to add the applications as an excluded "scheme" from this "security feature." But there's no information about how to determine what this scheme name is for the application you're looking to whitelist. Does anyone know what the scheme name is for vmware-cip-launcher.exe and the VMware Remote Console, or where that name could be found?

Thanks!

Additional references:

Full thread of workaround: Chrome 77, "always open these types of links in the associated app" is missed!!! - Google Chrome Hel...

Chrome commit: 4e0e7e532b04eef14f05077872629a2ccb763530 - chromium/src - Git at Google

1 Solution

Accepted Solutions
Contributor
Contributor

I have a machine which I ticked the boxes on before the Chrome change, so these are in my "preferences" file

"protocol_handler": {

  "excluded_schemes": {

   "vmrc": false,

   "vmware-plugin": false

  }

Hope that helps Smiley Happy

Update: be aware that you must place this in the correct location in the file. There are other locations that have "protocol_handler" already defined, and if you place the settings here it won't work. The JSON file is a complete mess to edit with a text editor, and it doesn't show the hierarchy of the settings. I used a more elaborate text editor which allowed me to use JSON syntax highlighting and then reformat the JSON file so that it showed the hierarchy of the settings. The "protocol_handler" section you want to edit (or you have to create it yourself) is at the "top level" of the settings, and normally just before the top-level "safebrowsing" section (as it is sorted alphabetically). However, there is another "safebrowsing" section under "protection"!

So, go to the end of the file, and then search backwards for "safebrowsing", and you should edit (or insert) the "protocol_handler" section just before there, such as

...},"protocol_handler":{"excluded_schemes":{"vmrc":false,"vmware-plugin":false}},"safebrowsing":{...

Sorry I can't be clearer on this, but I am far from a JSON file format expert Smiley Happy

Update 2: okay, I am making myself a little bit more versed with JSON files Smiley Happy if you've edited the file correctly, then this PowerShell command should return the following values

(Get-Content "$env:LOCALAPPDATA\Google\Chrome\User Data\Default\preferences" -Raw | ConvertFrom-Json).protocol_handler

excluded_schemes

----------------

@{vmrc=False; vmware-plugin=False}

If the output is blank (no "excluded_schemes" text), then the settings are in the wrong place in the file.

View solution in original post

10 Replies
Enthusiast
Enthusiast

Great question. I've tried vmware-cip-launcher as the scheme but that does not appear to be working.

This is what I tried: "protocol_handler":{"excluded_schemes":{"vmware-cip-launcher":false}}

0 Kudos
Contributor
Contributor

Would be really good to get this sorted. We hardly need extra clicks in a clicky world!

0 Kudos
Contributor
Contributor

I have a machine which I ticked the boxes on before the Chrome change, so these are in my "preferences" file

"protocol_handler": {

  "excluded_schemes": {

   "vmrc": false,

   "vmware-plugin": false

  }

Hope that helps Smiley Happy

Update: be aware that you must place this in the correct location in the file. There are other locations that have "protocol_handler" already defined, and if you place the settings here it won't work. The JSON file is a complete mess to edit with a text editor, and it doesn't show the hierarchy of the settings. I used a more elaborate text editor which allowed me to use JSON syntax highlighting and then reformat the JSON file so that it showed the hierarchy of the settings. The "protocol_handler" section you want to edit (or you have to create it yourself) is at the "top level" of the settings, and normally just before the top-level "safebrowsing" section (as it is sorted alphabetically). However, there is another "safebrowsing" section under "protection"!

So, go to the end of the file, and then search backwards for "safebrowsing", and you should edit (or insert) the "protocol_handler" section just before there, such as

...},"protocol_handler":{"excluded_schemes":{"vmrc":false,"vmware-plugin":false}},"safebrowsing":{...

Sorry I can't be clearer on this, but I am far from a JSON file format expert Smiley Happy

Update 2: okay, I am making myself a little bit more versed with JSON files Smiley Happy if you've edited the file correctly, then this PowerShell command should return the following values

(Get-Content "$env:LOCALAPPDATA\Google\Chrome\User Data\Default\preferences" -Raw | ConvertFrom-Json).protocol_handler

excluded_schemes

----------------

@{vmrc=False; vmware-plugin=False}

If the output is blank (no "excluded_schemes" text), then the settings are in the wrong place in the file.

View solution in original post

Contributor
Contributor

Wonderful. It took a bit of fiddling, as I did need to create a new protocol_handler section, and then it seemed to insist on changing my {"excluded_schemes":...} to {"excluded_schemes",*:...} which also screwed things up for a bit. But after closing the browser, clearing my cache, and editing the file in various orders of operation, it's working now. Thank you so much.

Contributor
Contributor

, thx you very much for this information.

In my Google Chrome 78 preferences file i have only one safebrowsing section. When i insert the protocol_handler at the this section nothing happens.

Your powershell script shows nothing, too.

I was able to fix the problem now. I create a new complete block on the top level.

"protocol_handler": {

        "excluded_schemes": {

            "vmrc": false,

            "vmware-plugin": false

        }

    },

Powershell command works, Chrome works! THX.

Tip: Use JSON Addon in the Notepad++ to change the file.

Contributor
Contributor

I am glad my convoluted notes fixed it for yourself and HWit1Smiley Happy

I tried to use PowerShell to edit the file as JSON, but it changed some of the text encoding on some other entries Smiley Sad

Otherwise a couple of lines of PowerShell would have fixed it in one go Smiley Happy

0 Kudos
Contributor
Contributor

I'm having the same problem but the fix detailed here does not work for me!

I'm using Chrome 79.0.3945.88

What I'm seeing is that I change the file, run the PowerShell command to verify its correct, which it is, then run the VCSA shortcut, and the same popup appears.

I check the PowerShell again, but nothing returned, I edit the file again and the change I made and verified has gone!

So, something is removing the change, some type of protection mechanism I'd suspect.

Anyone else seeing this or got any ideas?

Thanks in advance,

Steve

0 Kudos
Contributor
Contributor

This was happenning to me too.  I had to use Notepadd++, with the JSON language turned on for the change to take - it wouldn't take without JSON on. (Also ensure that there are no running copies of chrome before making the change)

0 Kudos
Contributor
Contributor

Worked for me. W2016 w/ vSphere 6.7 Update 3 in Chrome v80

0 Kudos
Contributor
Contributor

Thanks so much, worked with Version 81.0.4044.138..

I had two "SafeBrowsing" sections in the preferences file and putting the details you shared in before the first of the two worked.

Noticed if I had it in both places the session was slow to login and then wouldn't at times..

0 Kudos