lloydz
Enthusiast
Enthusiast

Can't vMotion VM to newly upgraded 6.5 host

Jump to solution

We have a shared storage cluster with 6 hosts that were all running ESXi 5.5.0, 3116895. We recently upgraded one of the hosts to VMware ESXi, 6.5.0, 8294253. Since the upgrade, we're unable to vMotion VMs to that host running 6.5. We get the following error message: "A general system error occurred: Launch failure. Transport (VMDB) error -45: Failed to connect to peer process. Cause:Transport (VMDB) error -45: Failed to connect to peer process."

We are able to migrate VMs to the 6.5 host if the VM is turned off. We're also able to vMotion live VMs to other hosts in the cluster - just not the new 6.5 host. We've tried a reboot of the host to no avail.

0 Kudos
1 Solution

Accepted Solutions
lloydz
Enthusiast
Enthusiast

We solved the issue.  We had previously ran the MacOS unlocker script on that host a few years back.  Apparently that was preventing the vMotion and subsequent powering on of the VMs.  After uninstalling the script and restarting the host, all is well.  Thanks for the replies!

View solution in original post

0 Kudos
4 Replies
ThompsG
Virtuoso
Virtuoso

Hi https://communities.vmware.com/people/lloydz,

Could you provide the following please:

  1. VMware.log from the affected machine after a failed vMotion
  2. Output from df -h

Kind regards.

0 Kudos
asajm
Expert
Expert

Can you check please vMotion communication settings

If you think your queries have been answered
Marking this response as "Solution " or "Kudo"
ASAJM
0 Kudos
lloydz
Enthusiast
Enthusiast

We solved the issue.  We had previously ran the MacOS unlocker script on that host a few years back.  Apparently that was preventing the vMotion and subsequent powering on of the VMs.  After uninstalling the script and restarting the host, all is well.  Thanks for the replies!

0 Kudos
serveradminist2
Contributor
Contributor

which script you uninstalling

0 Kudos