EADG
Contributor
Contributor

Can't log into MOB!

Hi,

I have the following problem, I need a readOnly User which is capable to log into the MOB of my Hosts (VMware 5.5). Via the webClient and SSO, I created a user and gave him the readyOnly Role for my entire structure.

With the newly created user, I can log in to the mob of the vCenter. When I try to log into the MOB of my Host I get a deny (the log in field pops up again). I also get a deny when I  try to use my root account to log in the mob of my Hosts.

I had taken a look with the vSphere-Client under the permissions-tab of my Host. Everywhere I see my newly created user with his role.

Any Suggestions?

Kind regards,

EADG

Tags (1)
2 Replies
GayathriS
Expert
Expert

By default, MOB is disabled on ESX/ESXi 6.x servers, and will need to be manually enabled.  To test if MOB  is enabled, follow the steps below:


1. Enter following URL in a browser, where x.x.x.x is the IP Address of the vCenter Server or ESX host:

http://x.x.x.x/mob

2. If MOB is enabled, the server will likely prompt you for credentials, and once entered, it will display the MOB Properties and Methods
3. If MOB is not enabled, the server will likely return an "HTTP 503 - Service Unavailable" error

Solution

To Enable MOB on an ESX Server

  1. Open the vSphere Client and navigate to the relevant Host
  2. Click on the Configuration tab
  3. On the left hand side under Software, click on "Advanced Settings"
  4. Expand the following nodes in the Advanced Settings tree:
  5. Config > HostAgent > plugins > solo
  6. Check the box next to "Config.HostAgent.plugins.solo.enableMob
  7. To confirm that MOB has been enabled on the Host, open http://x.x.x.x/mob, where x.x.x.x is the IP Address of the ESX Server

https://community.ipswitch.com/s/article/How-to-Enable-vmware-Managed-Object-Browser-MOB-on-an-ESX-H...

Please mark this as "correct" or " Helpfull" if this answers your query .

regards

Gayathri

EADG
Contributor
Contributor

Hi @

thanks for your answer but it is a 5.5 ESX-Host were MOB is enabled by default. I also checked it via command line with ```vim-cmd proxysvc/service_list``` and additionally I get a prompt where I can enter my Credentials.

Any other suggestions?

Greets,

EADG

0 Kudos