BHagenSPI
Enthusiast
Enthusiast

Can migrate some vms but not others

Jump to solution

I need to move some VMs around manually, within the same cluster of 6 esxi 6.7 hosts. This is a vsan cluster, with the VCSA sitting at Version:
7.0.1.00300, Build number 17491101.

Host13 has 15 vms on it; all are running Windows Server 2012 or 2016, and are running fine from an OS perspective.

I can migrate 10 of the 15 with no issues; I just click the vm, drag it to host12 (or any other host in the cluster), it migrates with no issues.

But 5 of them won't move; when I click and drag (or right-click-migrate), I get the message "This action is not available for any of the selected objects at this time."

vmotion-error-01.jpg

?? I have searched for that message for the last 2 hours and can't find any reference to it...my google-fu has failed me. 😞

Only one of the 4 have snapshots. None of the 5 have a CD connected. 

What else can I check?

Thanks!

0 Kudos
1 Solution

Accepted Solutions
BHagenSPI
Enthusiast
Enthusiast

Well, hmm. They're all migrating just fine this morning!

We'd had a network outage the night before last, and some of my Veeam backups had failed. The one vm that had a snapshot was due to Veeam; but none of the other VMs that wouldn't migrate had a snapshot, or a CD / ISO mounted.

Last night, all my Veeam backups completed properly.

This morning, I can migrate all the vms that didn't migrate yesterday.

Sheesh!

Case closed, I guess!

View solution in original post

0 Kudos
3 Replies
scott28tt
VMware Employee
VMware Employee

Tried initiating the migration from the Migrate menu of the VM?


-------------------------------------------------------------------------------------------------------------------------------------------------------------

Although I am a VMware employee I contribute to VMware Communities voluntarily (ie. not in any official capacity)
VMware Training & Certification blog
0 Kudos
microlytix
Enthusiast
Enthusiast

Hi @BHagenSPI 

Snapshots with CD image connected would be my first guess.

Are you sure that none of the snapshots has some iso mounted? You might not see it in the current state, but it can be hidden in some older snap.

blog: https://www.elasticsky.de/en
0 Kudos
BHagenSPI
Enthusiast
Enthusiast

Well, hmm. They're all migrating just fine this morning!

We'd had a network outage the night before last, and some of my Veeam backups had failed. The one vm that had a snapshot was due to Veeam; but none of the other VMs that wouldn't migrate had a snapshot, or a CD / ISO mounted.

Last night, all my Veeam backups completed properly.

This morning, I can migrate all the vms that didn't migrate yesterday.

Sheesh!

Case closed, I guess!

0 Kudos