sandy_1234
Enthusiast
Enthusiast

Automate Configuration of Identity Source on VCSA 6.0

Jump to solution

Hi All,

We are trying to create an identity source and set as a  "default: domain by executing the script residing in the directory /usr/lib/vmidentity/tools/scripts/sso-add-native-ad-idp.sh.

After the successful execution the script the domain we have added is not appearing as 'default'.

Eg:

/usr/lib/vmidentity/tools/scripts/sso-add-native-ad-idp.sh domain.com

Thanks in Advance.

Regards

Sandeep

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
sandy_1234
Enthusiast
Enthusiast

We could resolve the issues by following the guidlines mentioned below in the blog:

https://www.virtuallyghetto.com/2015/01/automating-active-directory-identity-source-default-domain-i...

Thanks

Sandeep

View solution in original post

0 Kudos
3 Replies
daphnissov
Immortal
Immortal

If you read the KB where this information is defined, it says you need to ensure you have already joined your PSC to Active Directory prior to running the script. Have you done that already?

0 Kudos
sandy_1234
Enthusiast
Enthusiast

We have joined the domain prior to running the command below. Adding to domain has turned out to be successful.

/opt/likewise/bin/domainjoin-cli domain_admin domain_password

Thanks

Sandeep

0 Kudos
sandy_1234
Enthusiast
Enthusiast

We could resolve the issues by following the guidlines mentioned below in the blog:

https://www.virtuallyghetto.com/2015/01/automating-active-directory-identity-source-default-domain-i...

Thanks

Sandeep

View solution in original post

0 Kudos