vAndrew
Enthusiast
Enthusiast

Auto-Negotiation Issues

We seem to have issues with using 2 NICs in our environment, there are 5 hosts, all with 2 spare NICs that we have used to create a new vSwitch and assign the ports to.

Of the 10 NICs in use, 7 of them auto-negotiate to 1GB full duplex without issue, however, we have 3 that don't and the only seem to negotiate to 10MB on 2 of them and 100MB on the other. We've change cables, swapped switch ports and its made no difference. Cables and switch are fine.

If we try to force it to 1000MB full duplex, it shows down in vCenter and doesn't come back up until its set back to auto.

Firmware and drivers are all the same, i'm thinking faulty NIC ports unless anyone has any other ideas?

-- Andrew (VMware VCP-DCV, MCSA)
0 Kudos
3 Replies
Alex_Romeo
Leadership
Leadership

Hi,

If I understand your problem correctly this could help you.

VMware Knowledge Base

Duplex Mismatch

  • A common issue with speed/duplex is when the duplex settings are mismatched between two switches, between a switch and a router or between the switch and a workstation or server.
  • This can occur when manually hard coding the speed and duplex or from auto negotiation issues between the two devices.

ecc...

ARomeo

Blog: https://www.aleadmin.it/
0 Kudos
vAndrew
Enthusiast
Enthusiast

The settings arent mismatched, everything is set to auto, both ends. Its not negotiating at 1000MB thats the issue, but only on one of the NICs. Cant force it as it shuts the NIC down and will only work on auto.

Drivers and firmware are the same across all hosts. The issue is seemingly with that NIC

-- Andrew (VMware VCP-DCV, MCSA)
0 Kudos
Alex_Romeo
Leadership
Leadership

Hi,

I advise you to contact the technical support of the hardware, I am quite sure that it could be a malfunction of the network card.

If you call support, post the resolution so maybe it can be useful to other people.

Thank you

ARomeo

Blog: https://www.aleadmin.it/
0 Kudos