Bilal233
Contributor
Contributor

vsan host is in maintenance mode

Hi Expert ,

 My vsan cluster's one node is in maintenance mode :

Maintenance Mode state: ON ( this is vsan node ) although my host is ok condition and not in maintenance mode .

how i can disabled Maintenance mode off.

plz help, my other host is working fine only one node vsan host is in maintenance mode and not participating in cluster .

Bilal233_0-1626416658362.png

 

0 Kudos
3 Replies
TheBobkin
VMware Employee
VMware Employee

@Bilal233, if no VMs are running on it then from the vSphere UI put the node in Maintenance Mode with 'No Action' option and then immediately take it out of MM.

0 Kudos
sunvmware1
Enthusiast
Enthusiast

Hi,

If you want to maintenance mode off, try below cli commands.

  1. Check whether the host is in maintenance mode.
    esxcli --server=<server_name> system maintenanceMode get
     
     

Place the host in maintenance mode off.

esxcli --server=<server_name> system maintenanceMode set --enable false

 

Verify that the host is in maintenance mode.

esxcli --server=<server_name> system maintenanceMode get
 
 
https://docs.vmware.com/en/VMware-vSphere/7.0/com.vmware.esxi.upgrade.doc/GUID-698094CD-8807-4954-83...
0 Kudos
TheBobkin
VMware Employee
VMware Employee

@sunvmware1 , Unfortunately that won't actually work here - the host is not in ESXi/vSphere MM, that will just return 'false' when checked and setting this to false won't change anything.


@Bilal233 , aside from the MM/NODE_DECOM_STATE (which what I said above should fix without issues), I missed your point about it being isolated:

Was this host removed from the vSphere cluster?

Does it have a vsan-enabled vmk tagged and can vmkping the other nodes IPs from it?

Is the unicastagent list on it fully populated? (and do the other nodes have this nodes unicast entry)

 

0 Kudos