seamusobr1
Enthusiast
Enthusiast

vsan.clombgprorebalanceenabled

Jump to solution

Recently a health alarm appeared saying that vsan.clombgprorebalanceenabled was not set

Does anyone know what this advanced setting is there is nothing on the web about it. I assume it is something to do with the automatic rebalancing feature in 6.7 u3

Thanks in advance

Labels (1)
0 Kudos
1 Solution

Accepted Solutions
TheBobkin
VMware Employee
VMware Employee

@seamusobr1 Is this cluster in the middle of an upgrade?

What build version is the vCenter and all hosts on? (including Witness if applicable).

Yes, this is related to automatic rebalancing which is configured at the cluster level and the setting pushed down to all nodes - have you configured this?

If so, then if the changed setting has been implemented on the hosts the setting on the host should return '1' for:

#esxcfg-advcfg -g /VSAN/ClomBgProRebalanceEnabled

View solution in original post

0 Kudos
2 Replies
TheBobkin
VMware Employee
VMware Employee

@seamusobr1 Is this cluster in the middle of an upgrade?

What build version is the vCenter and all hosts on? (including Witness if applicable).

Yes, this is related to automatic rebalancing which is configured at the cluster level and the setting pushed down to all nodes - have you configured this?

If so, then if the changed setting has been implemented on the hosts the setting on the host should return '1' for:

#esxcfg-advcfg -g /VSAN/ClomBgProRebalanceEnabled

View solution in original post

0 Kudos
seamusobr1
Enthusiast
Enthusiast

Hi yes sort of

I think I know what the issue is the hosts are 6.7 u3 but the witness appliance is 6.5

so when the command is run as below the witness appliance will not return a 1

Thanks for your help

0 Kudos