lennyburns
Enthusiast
Enthusiast

vSAN not recognising SSD even after i manually tag it as SSD...

Jump to solution

I am building a POC lab using a C7000 chassis full of blades and with local storage.

I want to leverage the local storage via the vSAN product.

I have installed the USB sticks in the servers and have successfully deployed ESXi 5.5u1 to each server and carved the local drives into a RAID0 (pass-through isn't available on the RAID controller installed).

I then created two RAID 0 drives on the media.

1 drive is 22Gb

1 drive is 222Gb the remainder of the space.

I have tagged the 22Gb drive as SSD, and the vCenter clients all show this as an SSD drive.

I set up all the vSAN networks and requirements, then I go to set up the first disk group, and this is when it stops.

When go to configure a disk group on a host, i am asked to select 1 SSD and select one non-SSD drive, and the screen shows the non-SSD drive, but the list of SSD drives is empty.

I have rebooted and even rebuild the hosts RAID volumes from the ground up.

I also have made sure that NO VMFS partition has been placed on it.

What is wrong?

I have noticed one anomaly...

When I go to "detach" the SSD drive so that I can free the path ownership (for diagnostic reasons) I notice that I cannot.

It fails saying that there is a Diagnostic partition on this disk, so it refuses.

I believe this might be the problem, so, how to I prevent this volume from being touched?

Tags (3)
0 Kudos
1 Solution

Accepted Solutions
lennyburns
Enthusiast
Enthusiast

Okay so that anomaly?

That was it.

Sneaky Sneaky ESXi with it's auto partitioning for coredumps was the culprit.

I followed this advice on using a remote coredump collector and then blew away the partition scheme on the drive tagged as SSD, and it appeared.

http://www.virten.net/2014/02/permanently-disable-esxi-5-5-coredump-file/

Do this and you're golden.

View solution in original post

0 Kudos
1 Reply
lennyburns
Enthusiast
Enthusiast

Okay so that anomaly?

That was it.

Sneaky Sneaky ESXi with it's auto partitioning for coredumps was the culprit.

I followed this advice on using a remote coredump collector and then blew away the partition scheme on the drive tagged as SSD, and it appeared.

http://www.virten.net/2014/02/permanently-disable-esxi-5-5-coredump-file/

Do this and you're golden.

0 Kudos