ShuklaJI
Contributor
Contributor

vSAN HCI Mesh - Unable to unmount Remote datastore vSAN

Hi Everyone,

I am writing this as question because not sure what i did to resolve this issue was correct way to do or not.

Happy to see the new feature introduced with vsphere 7.0.1 HCI Mesh vSAN which allow to share the existing vSAN with other cluster having HCI ready Nodes without local disk. All seems pretty good and easy to configure the HCI Mesh vSAN, In my lab i already had a cluster "Main vSAN Cluster" which using the local vSAN with local disk on each Esxi host, I created another cluster where i added newly created Esxi hosts (vSAN ready) which don't have there own local disk installed and i successfully able to mount the existing vSAN datastore as remote datastore in new cluster which had only 2 nodes (esxi 7.0.2) installed.

ShuklaJI_0-1624085742437.png

ShuklaJI_1-1624085907158.png

Now the problem occurred when i was done with my testing and trying remove the newly created cluster by simply un-mounting the remote datastore, Option was grayed outand saying that "Cannot unmount the datastore because this cluster has registered virtual machines on it." where actually i don't have any running VM left in cluster, it was because of another feature of Vsphere 7 U1 called as vCLS which itself a great thing introduced and very helpful while vCenter temporally Maintenance/Disconnect but the thing is that it create hidden service VM's which actually created on the vSAN datastore which was mounted remotely from the existing vSAN. Now problem is unmount operation can't be done unless all VM's will be evacuated or deleted, another problem is system not allowing to delete/manage vCLS VM's. I found an document from Vmware on unmount the Remote vSAN datastore but unfortunately the option mentioned in document was not really exist in my case that i assume. I even tried to remove all hosts from cluster then even it was not allowed to unmount the remote vSAN datastore and not even allowing to delete empty cluster. Not even it was allowed to turn off vSAN services on remote vSAN cluster.

ShuklaJI_2-1624086171763.pngShuklaJI_3-1624087465687.png

ShuklaJI_4-1624087914186.pngShuklaJI_5-1624088009983.png

 

I solved this problem by myself and for that i tried different approach but not sure if that all were correct way to do or not. First solution i marked as best and easy one because it was looks so easy and promising. This issue occurred because my lab environment was on purely vSAN and vCLS vm's were created on vSAN datastore which not allowed to delete and due to that Unmout was grayed out.

Solution 1 :

  1. Put all host from "HCI ready clsuter" (remote vSAN cluster) in Maintenance Mode.
  2. Move out the hosts which were maintenance mode, out of cluster to directly vCenter/Folder.
  3. Shutdown hosts which we take out of cluster under MM.
  4. Navigate to Main vSAN Cluster and select the File Tab. Now select the vCLS VM that were used in remote vSAN cluster "HCI vSAN Ready" and delete them.ShuklaJI_7-1624089449794.png

     

  5. Power On back those host which was removed in Step 1.
  6. Add then back to same vSAN remote HCI cluster."HCI vSAN Ready" and let them in Maintenance mode. You may see some error while deploying the new vCLS VM which we can ignore.
  7. Now navigate to Remote cluster "Configure" --> vSAN --> Remote Datastores.
  8. Select the desired vSAN datastore and now Unmout option will be highlighted. Just click on unmount and it will remove it.ShuklaJI_8-1624089503039.png

     

    ShuklaJI_6-1624089393246.png
  9. Turn off vSAN service after successful unmount of remote datastore.

Final step is for clean up. You may see some inaccessible VM which are actually vCLS VM's GUID which we deleted when host were down. Just unregistered those VM and all set as a clean removal.ShuklaJI_0-1624090354687.png

=====================================================================================================

Alternative Solution which i applied also worked:

Solution 2:

1.) Add Software ISCSI adapter and added a temporarily ISCSI datastore to all host in Remote vSAN datastore cluster.

2.) Moved all vCLS VM's to newly added ISCSI based datastore.

3.) Unmount the Remote datastore and turned off the vSAN services.

5.) After that turned off all hosts and removed from inventory because i decommissioned those test esxi.

6.) Then just deleted the temporary ISCSI created along with its vCLS's VM's

7.) Master cluster hosting the vSAN didn't get impacted due to this and still running fine after this.

This is also looks easy to do without any harm in case of decommission of hosts only.

 

Solution 3:
This solution using VMware Cluster Retreat Mode.
NOTE: Caution using this solution because this will stop the DRS and HA feature from cluster. Use this only in case all hosts will be removed from cluster and ensure no VM is running.
1.) Use the Vmware document to enable the Retreat Mode which disable the vCLS' VM and also remove them by system itself.

2.) Unmount datastore.

3.) Disable vSAN services on Remote cluster which was using the vSAN shared from Main cluster.

I didn't found any Vmware article or Document which was written for Pure vSAN environment where vCLS VM's not allowing to unmount the datastore.

===============================================================================================

Would appreciate if anyone know other clean and easy way to do the same. I am still not sure what i did was the correct way to do so or not.
Thanks !!

0 Kudos
1 Reply
depping
Leadership
Leadership

the way to do this is via retreat mode! That is why we introduced this option. It deletes the VMs for you, which then enables you to unmount the datastore

0 Kudos