bilalfuuu
Enthusiast
Enthusiast

how to enable HBA/Passthrough Mode in HP Gen 10 , controller P408i-p

Hi Expert ,

i need help .

how to enable pass-through or HBA mode in HPE Gen 10 with Controller P408i-p ,

i want to run the command

esxcli hpssacli cmd -q “controller slot=<slotnumber> modify hbamode=<on/off> forced”

esxcli ssacli cmd -q “controller slot=<slotnumber> modify hbamode=<on/off> forced”

but this command not running , i tried to install all drivers but nothing happened , even i run updated SPP .

one more thing i cant enter storage administrator cli mode though SPP with ctrl+alt+d+b+x.if procedure is different entering  into cli mode , kindly also mentioned it.

if somebody deployed vSAN on HPE Gen 10 with Passthough Mode , kindly help me  to figure out this .

Thanks

Bilal Ahmed

14 Replies
TheBobkin
VMware Employee
VMware Employee

Hello Bilal,

Can you please try configuring this via the BIOS?

If you had it (incorrectly) configured as RAID0, then place the node in Maintenance Mode with 'Full Data Evacuation' mode (ensure you have space to do this on the remaining node), remove the disk-groups, in BIOS remove the individual RAID0 VDs for each disk attached to the controller, change the controller mode to HBA/passthrough (or 'Mixed' if passthrough is not a configurable option as it is on some controllers), reboot, recreate the Disk-Groups.

Ensure you are using the correct driver+firmware for the vSAN version in use:

VMware Compatibility Guide - I/O Device Search

Bob

0 Kudos
vpradeep01
VMware Employee
VMware Employee

Hello bilalfuuu

Try this command once. Also have you upgraded the firmware on the controller? Could you try to upgrade the FW first and then enable pass-through?

hpssacli controller slot=<slotnumber> modify hbamode=<on/off> forced

0 Kudos
bilalfuuu
Enthusiast
Enthusiast

Hi ,

i tried it , but nothing happened , updated firmware through Latest SPP  but passthough mode command not running  also HBA mode not found in HP gen 10 .

0 Kudos
bilalfuuu
Enthusiast
Enthusiast

Hi Bob,

i cant find passthough and HBA mode in Bios , have you ever experience it to enable passthough mode in P408i controller , kindly let me know.

needy firmware already updated though SPP but still i cant run this command .

esxcli hpssacli cmd -q “controller slot=<slotnumber> modify hbamode=<on/off> forced”

0 Kudos
TheBobkin
VMware Employee
VMware Employee

Hello Bilal,

I am not positive if it was this controller or another but I recall some newer controller only having 'Mixed' mode selectable - provided this is configured and there is no actual mixing of modes (e.g. some disks in passthrough, others with RAID0/RAID1) this should be fine (as there is no other selectable option).

If this is a 6.5 or later cluster then try calling the binary directly e.g./opt/smartstorageadmin/ssacli/bin/ssacli

HPE Smart Array CLI commands on ESXi | Kalle's playground

Bob

0 Kudos
bilalfuuu
Enthusiast
Enthusiast

Hi ,

In vmware HCI , this controller support passthrough mode but i cant run the command or find HBA/ passthough mode in this controller , in storage administrator setting it only shows mix mode .

0 Kudos
TheBobkin
VMware Employee
VMware Employee

Hello Bilal,

Yes, as I said in my last comment..

If only mixed mode is available as option on the controller then use this and only have disks configured as passthrough (no RAID of any form).

I recall it being  basically a case of we are not changing the HCL listing to state ''mixed" for controllers like this as surely some folk will set up a mix of passthrough and RAID1/RAID0 disks and think it is fine (it's not).

Engage HPE if you think there is another way but this sounds exactly what I went through when this/similar controller was first put forward for certification testing (on our side).

Bob

0 Kudos
bilalfuuu
Enthusiast
Enthusiast

Thanks Bob ,

i engage the HPE Engineer , if they find any other way , i will share  you ,..

again i updated Firmware and utility of controller , now let see what happened today .

iforbes
Hot Shot
Hot Shot

Hi. Did you find the way to change the mode to HBA mode? I have the exact same controller.

Thanks

0 Kudos
HFMudd
Enthusiast
Enthusiast

HPE Smart Array Controllers are pass-through/HBA mode by default that only changes if you configure an array. If you configure an array using only some drives the remaining drives will operate in pass-through/HBA mode making the controller operate as mixed-mode. I hope that makes sense.

0 Kudos
iforbes
Hot Shot
Hot Shot

You're saying that if I go and destroy any RAID arrays created, it will now show up as HBA mode? I should be able to look in the HP Storage Administrator and see the mode of the controller. With no arrays configured will it specify anything (i.e. HBA mode)?

I get that it's a mixed mode controller but all HP info state you have to actually configure the controller to HBA mode. Is this controller somehow different?

0 Kudos
HFMudd
Enthusiast
Enthusiast

It's either going to act as pass-through/HBA if there is no array/RAID configuration. It's default behavior is pass-through aka HBA which is typified as no-RAID. To my knowledge I don't know that SSA will actually describe the mode as Pass-Through or HBA, you can look.

If you have HP doc that says you have to configure HBA mode for this controller you'll have to provide the doc.

From HPE Smart Array SR Gen10 User Guide: https://support.hpe.com/hpsc/doc/public/display?docId=emr_na-a00019059en_us

"Any drive that is not a member of a logical drive or assigned as a spare is presented to the operating

system. This mode occurs by default without any user intervention and cannot be disabled."

iforbes
Hot Shot
Hot Shot

Interesting. You have to actually enable HBA Mode for the P440, so thought the process was the same. Thanks.

0 Kudos
mysy
Contributor
Contributor

I'm use the Gen10 DL20 server too,

The E208 or P408 all call smart array Gen10

It doesn't use switch mode between HBA or Raid. Now HPE use Mixed mode to use HBA disk and Raid disk in same card with same SAS port.

pastedImage_0.png

When use add a disk without create new array to init it, it will be the HBA mode to through Disk to OS.

I use the bios mean of my E204i-a card.

I connect two SSD disk to it. one are use create array mode to use it for Raid0 mode, other one not create array.

So one disk show use Raid mode , and associated to array xx

other one not use raid array:

it show HBA mode , and direct show the disk temperature.

0 Kudos