SCMHenry
Enthusiast
Enthusiast

VSAN witness appliance maximum latency

Jump to solution

I have deployed a 2-node VSAN cluster at a remote site, with a VSAN witness appliance located in the main datacenter.

I am typically seeing latency of between 55 and 60ms between the VSAN storage nodes and the witness appliance.... just slightly more than the 50ms published requirement.

Of course this is triggering an error as far a the VSAN health check is concerned.

The VSAN itself seems to be functioning alright, at least superficially.

What is the maximum acceptable value for latency?

Do I need to find another location to host the witness appliance so that I can reduce the latency to less than 50ms, or can I continue operating in this mode?

Lastly, assuming that 60ms latency is tolerable, can I modify the health check test to be just a little more tolerant of increased latency results?

THANKS

0 Kudos
1 Solution

Accepted Solutions
depping
Leadership
Leadership

this is a known issue, I have reported this a while ago and it should be fixed with a next patch, you can safely ignore the warning. 500ms is the threshold for ROBO and 200ms for stretched. Sorry about this,

View solution in original post

0 Kudos
3 Replies
zdickinson
Expert
Expert

Good morning, not sure why 50 MS would trigger a warning.  The threshold is 500 ms.  For two node ROBO configurations, there is a 5ms RTT between data sites and a 500ms  RTT between the data sites and the witness. From A closer look at the VSAN witness appliance - CormacHogan.com

Thank you, Zach.

depping
Leadership
Leadership

this is a known issue, I have reported this a while ago and it should be fixed with a next patch, you can safely ignore the warning. 500ms is the threshold for ROBO and 200ms for stretched. Sorry about this,

0 Kudos
SCMHenry
Enthusiast
Enthusiast

Thanks for the explanation, Duncan!

And apologies for my confusion about whether the threshold was actually 500ms vs 50ms.

0 Kudos