compwizpro
Enthusiast
Enthusiast

VSAN File Services AD OU with space

Jump to solution

Hello,

I am trying to enable VSAN file services with Active Directory integration so I can create SMB shares.  Our organization prevents the use of the default Computers OU for computer account creation so I either need to pre-create the computer AD object or specify the Organizational unit value during the VSAN file services domain setup.  Since the VMware documentation says pre-created computer AD objects are not supported, I need to go with the latter option above.

Our Organizational Unit names have spaces in them and when put the OU path as described by the documentation I get the error "The organizational unit cannot contain any special characters, except forward slash /"  My OU example is like this: Org Unit1/OrgUnit2/Org Unit3.  If I enter it as OrgUnit1/OrgUnit2/OrgUnit3 where there are no spaces, I don't get the error and can move forward to the next screen.

Is there a limitation where there can't be any spaces in the Organizational Unit name paths?  This isn't indicated in the VMware documentation I was following here: Configure File Services (vmware.com)

Thanks!

Labels (3)
0 Kudos
1 Solution

Accepted Solutions
depping
Leadership
Leadership

Just got the confirmation, it is a known limitation indeed. I will try to get the documentation updated asap, and I will ask if/when we are planning on fixing this. Thanks for raising this.

View solution in original post

0 Kudos
6 Replies
depping
Leadership
Leadership

I have just asked the engineering team, I have not tried this myself, but it wouldn't surprise me if this is a known limitation.

0 Kudos
depping
Leadership
Leadership

Just got the confirmation, it is a known limitation indeed. I will try to get the documentation updated asap, and I will ask if/when we are planning on fixing this. Thanks for raising this.

0 Kudos
compwizpro
Enthusiast
Enthusiast

Thank you very much for checking on this!  I will move forward by specifying OUs not containing a space.

Thanks!

DanielRoeber
Contributor
Contributor

Hey Duncan,

has there been an evolvement on the subject (that I hopefully missed)? We are running into the exact same situation ... using OUs without spaces is not an option I am afraid ... .

 

Thank you.

 

0 Kudos
depping
Leadership
Leadership

I have no update unfortunately, this hasn't been fixed just yet.

0 Kudos
compwizpro
Enthusiast
Enthusiast

One workaround we did was create / use a temporary OU that had no spaces to first go through the creation process.  Once it was complete and the computer objects were created, we moved them into an OU that has spaces and could continue to access the file shares.  It appears it just needs an OU with no spaces as part of the domain join process.

Hope that helps.