AntonioMBLS221
Contributor
Contributor

Upgrading vSAN on environment w/ VMware Replication and SRM

I'm in the process of upgrading vCenter 6.0 to 6.7 on windows for protected and recovery sites with VMware Replication and SRM. What is the correct order/sequence in which we should upgrade these in and the procedure for vSAN upgrade at protected site?

Versions:

  Protected Site with vSAN Datastores

vCenter Server w/ embedded Platform Services Controller6.0.0.24788
VMware vCenter Site Recovery Manager6.1.2.16353
VMware vCenter Site Recovery Manager Embedded Database9.3.22.0
VMware vSphere Client 6.06.0.0.7236
VMware vSphere Update Manager6.0.0.35637

Recovery Site with Dell EqualLogic Datastores

vCenter Server w/ embedded Platform Services Controller6.0.0.24788
VMware vCenter Site Recovery Manager6.1.2.16353
VMware vCenter Site Recovery Manager Embedded Database9.3.22.0
VMware vSphere Client 6.06.0.0.7236
VMware vSphere Update Manager6.0.0.35637
2 Replies
TheBobkin
VMware Employee
VMware Employee

Hello AntonioMBLS221​,

Welcome to Communities,

This article covers the basics of what you need to look into here:

VMware Knowledge Base

Namely, get familiar with the VMware interoperability matrices:

VMware Product Interoperability Matrices

And the update sequence guides for the vSphere versions you are upgrading to (assuming all of the component products are backwards compatible with the versions you are upgrading from):

VMware Knowledge Base

Bob

0 Kudos
MJMSRI
Enthusiast
Enthusiast

Hi, this Article below details some good examples of upgrades that should help you plan this.

VMware Knowledge Base

  1. it sounds like you are using windows vcenter, so I would use this project to migrate and upgrade at the same time to VCSA 6.7: Migrating vCenter Server for Windows to vCenter Server Appliance
  2. there is no upgrade path from your SRM version to the latest SRM release and that will also be on a windows VM so I would look to export the config, deploy a new SRM Appliance and import the config. for compatability with any vCenter 6.7 release you would need to have SRM version 8.1 as a minimum.
  3. Also don't forget to check your Dell arrays compatibility as both sites should be on the same version of vSphere. looking at this it looks like all are supported to vSphere 7.0 so 6.7 should be ok VMware Compatibility Guide - Storage/SAN Search