roffty
Contributor
Contributor

NTP settings on host <esxi host> is different from the desired settings.

Hi,

I have created a vSan Cluster via Quickstart configuration. The Cluster itself is running and healthy. After the deployment I changed the NTP Settings of my vCenter Server Appliance and ESXi hosts. The Skyline Host compliance check for hyperconverged cluster configuration now shows me the warning “NTP settings on host <esxi host> is different from the desired settings.”.

sshot-1.png

https://kb.vmware.com/s/article/58896 states:

„4. NTP setting
NTP setting on hosts should be the same with the specifications. NTP setting will be persistent if it's configured via QuickStart and health check reports a warning if the NTP setting on the host is not consistent with the cluster level. If NTP is not configured in QuickStart, the health check will not validate NTP compliance status, then the user can configure it on the host later.
How to set NTP.“

Is there a way to change the NTP settings set during Quickstart / the value to validate against?

Or is my only option to recreate the cluster / silence the alert?

Thanks

15 Replies
TheBobkin
VMware Employee
VMware Employee

Hello roffty​,

Welcome to Communities.

What build of ESXi/vCenter in use here?

I haven't had the time to validate what (if any) changes to this there have been in 7.0 U1, but in 6.7 U3/7.0 GA this is unfortunately not configurable/changeable after inception e.g. if the settings have changed to be something other than the initial Quickstart configuration then they will always appear as non-compliant (as they are) and thus it is a case of going with the options of recreate or silence the alert.

I will ping back here when I get around to doing more in-depth testing of whether this is the case in 7.0 U1.

Bob

0 Kudos
roffty
Contributor
Contributor

Hello TheBobkin,

Thank you!

vCenter

Version: 7.0.1 Build: 16858589

ESXi:

Version: 7.0.1 Build: 16850804

Roffty

0 Kudos
LaBaSuS01
Contributor
Contributor

Hello,

 I have the same warning in vSAN skyline health with VMware ESXi, 7.0.1, 16850804

0 Kudos
LaBaSuS02
Contributor
Contributor

Hello TheBobkin,

Any good news about this issue? If the vSAN in production state, we cannot rescreate it, and customer hate some stuff like warning ignoring...

Can we do some esxcli magic or any else to resolve this problem?

0 Kudos
Bill_Oyler
Hot Shot
Hot Shot

Same issue here.  Used Quickstart wizard to configure a single NTP server, then added a second NTP server later on.  Cannot find a way to update Quickstart parameters such as NTP servers, post deployment.  This is vCenter 7.0U1c and ESXi 7.0U1c.  This is a fairly major limitation with Quickstart, as editing parameters such as NTP servers should be very routine and non-disruptive.  Can this be flagged as an issue to get resolved in a future update?

Bill Oyler Systems Engineer
0 Kudos
MrJazze
Enthusiast
Enthusiast

I've recently built a 3 node x 7.0.2 cluster and the QuickStart has the exact same issue. I changed my NTP server per each host and VCSA, now QuickStart shows all nodes are non-compliant NTP Settings. I've searched web client for a way to reset with no avail.

0 Kudos
qwertykolea1
Contributor
Contributor

Greetings, there was the same problem.
I decided to add ntp servers VMware:
89.28.86.96,217.26.163.51

0 Kudos
rpe65
Contributor
Contributor

Same here with 7.0U2a (ESXi hosts) / 7.0U2b (vCenter)... Is there really no way to change the "specifications" after cluster setup? Can't believe it...

0 Kudos
depping
Leadership
Leadership

That is weird, let me see if I can get an answer to this for you folks.

0 Kudos
depping
Leadership
Leadership

Just did some searching around internally, and it is a known issue indeed. I am raising it again with the engineering team and the Product Manager to get this fixed.

0 Kudos
stoffl2610
Contributor
Contributor

Hi,

I'm having the same issue on a 3-Node Cluster. Do you know anything new

vCenter 7.02

vSphere 7.02 customized Fujitsu Image

stoffl2610_0-1625599238872.png

 

0 Kudos
APJ_vm
Enthusiast
Enthusiast

Hi, is there somewhere that customers can go to, to "upvote" the fix for this. Or is there a PR number we can give to our TAM's. 

0 Kudos
depping
Leadership
Leadership

there's no PR for a fix, it is a roadmap item.

0 Kudos
holinhot
Contributor
Contributor

I fixed it

 

A lite bit risky, so recommended to backup your VCSA before operation


login your VCSA via SSH

Enter postgres
/opt/vmware/vpostgres/current/bin/psql -U postgres -d VCDB


you can get your cluster_id of vSAN by the following SQL:

select * from vc.vpx_hci_config_info;

 

Get current configuration by the following SQL:
select datetime_config from vc.vpx_hci_config_info;

 

Update configure:

update vc.vpx_hci_config_info set datetime_config='<obj xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns="urn:vim25" versionId="7.0.1.1" xsi:type="HostDateTimeConfig"><ntpConfig><server>8.8.8.8</server><server>1.1.1.1</server></ntpConfig></obj>' where cluster_id=24;

 

after updated
Need to restart VCSA it seems that vSAN has loaded the configuration into memory so Updating the configuration in DB does not work if without restart VCSA

0 Kudos
Tibmeister
Expert
Expert

Use the PowerCLI AddHostNtpServer commandlet, don't go messing around with the database.  Personally, I skip the quickstart and have my own configuration script to set my common settings.  It is a hold over from ESX 6.x days, but I've heard of some craziness with QuickStart that makes me think it's better to keep a simple script around.

0 Kudos