ManivelR
Enthusiast
Enthusiast

LSI 9207-8i storcli for ESXi 6.7.0 u1 VSAN

Hi All,

I was using H710P DELL RAID controller(VSAN disks was in RAID 0) and just replaced the H710P with LSI 9207-8i HBA cards.After replacing the HBA LSI card,automatically all the VSAN disks detected under new "LSI 9207-8i HBA card". We haven't deleted and re-created the disk groups as it was automatically fetched.

Earlier RAID 0 configuration was SSD-->No read ahead,write through,disabled disk write cache.

Pass through will be enabled by default under LSI 9207-8i HBA card ? or do i need to do anything from BIOS setting?

When im trying to see the controller summary using the below storcli command,it shows "no of controllers=0" but the controller is listed in ESXi server/VC.(I see all the current disks under this new LSI HBA cards).

And tried sas3flash utility as well.

pastedImage_6.png

My ESXi version is 6.7.0 U1.

Device Name: vmhba1

   Device Display Name: LSI Logic / Symbios Logic LSI2308_2

   Used By VSAN: true

   PCI ID: 1000/0087/1000/3020

   Driver Name: lsi_msgpt2

   Driver Version: 20.00.04.00-5vmw.670.1.28.10302608

   Max Supported Queue Depth: 10104

   Firmware Version: N/A

[root@hv-01:/tmp] esxcli software vib install -v /tmp/VMwareOP_Certified/vmware-storcli.vib --no-sig-check

Installation Result

   Message: Operation finished successfully.

   Reboot Required: false

   VIBs Installed: LSI_bootbank_vmware-storcli_007.0916.0000.0000-01

   VIBs Removed:

   VIBs Skipped:

[root@hv-01:/tmp] cd /opt/lsi/storcli/

[root@g3-sf10-314-hv-01:/opt/lsi/storcli] ./storcli show

CLI Version = 007.0916.0000.0000 Apr 05, 2019

Operating system = VMkernel 6.7.0

Status Code = 0

Status = Success

Description = None

Number of Controllers = 0

Host Name = hv-01

Operating System  = VMkernel 6.7.0

StoreLib IT Version = 07.0906.0200.0000

StoreLib IR3 Version = 16.05-0

Tried with sas3flash as well,

hv-01:/opt/lsi/bin] ./sas3flash -listall

Avago Technologies SAS3 Flash Utility

Version 16.00.00.00 (2017.05.02)

Copyright 2008-2017 Avago Technologies. All rights reserved.

        No Avago SAS adapters found! Limited Command Set Available!

        ERROR: Command Not allowed without an adapter!

        ERROR: Couldn't Create Command -listall

        Exiting Program.

Could you please advice what i need to do here?

Thanks,

Manivel R

5 Replies
ManivelR
Enthusiast
Enthusiast

Some one might be confused after reading the above one.My apologies for that.

We are in testing phase/pre-prod and using R820 DELL servers with All flash VSAN 6.7 u1(we dont have enough budget to get a VSAN recommended one).

As the integrated RAID controller H710P of DELL R820 servers are not performing well,we like to change the RAID controller(H710P) to LSI HBA card(9207-8i).

As of now,we changed the LSI HBA card(with the help of DC team) on one ESXi server and we have not done anything from VSAN side(no config changes done).Immediately all the 8 VSAN disks attached to the new LSI HBA card(9207-8i).

My doubts:- For example,R730 RAID card.If i want to change  from RAID0 to HBA mode(passthrough),then we used to change "change to non raid" from BIOS to make the controller as a pass through.Before doing this,we need to evacuate all the data from VSAN DG and then it should be deleted.This is the recommendations from VMware

Like that, any changes is needed on my LSI HBA card(9207-8i)from ESXi side/VSAN side ?????

HBA card screenshot:-

pastedImage_0.png

I was not updated any firmware/driver to LSI HBA cards from broadcom website.It still uses the default driver from ESXi 6.7.0 u1.

pastedImage_2.png

And Im seeing the queue depth is 10104 from new LSI HBA card.Its surprising.Any ideas?

pastedImage_1.png

Thanks,

Manivel R

0 Kudos
tankren
Contributor
Contributor

Hello there, I got the similar problem with H220 (Avargo/LSI 9205-8i) under Esxi 6.7 U3 on ML310e Gen8 V2.

the card shows in storage adapters list, mounted disk can be seen also. however, sas2flash said no card detected, and if I passthrough this H220 to debian or freeNAS vm, the VM system won't boot. Debian said mpt2sas_cm0: fault state and freeNAS said mps0: IOC in unexpected reset state.

tried to flash the card to lastest LSI firmware but the same problem, then I switched to 6.0 u3 which is officially supported by HPE, the problem is gone.

Still looking forward to make it usable under 6.7 u3, 6.0 u3 is really slow...

ju0594
Contributor
Contributor

I have LSI Logic SAS 9207-4i4e under Esxi 6.7 U3 on ProLiant DL320e Gen8 v2,I got the same problem...

I passthrough this card to Debian and start it,after a few seconds it show "mpt2sas0: fault_state" and Shutdown...

0 Kudos
tankren
Contributor
Contributor

hello there,

     have you fix the issue? thx

0 Kudos
ju0594
Contributor
Contributor

Hi, I've tried many versions and the highest version that works fine is 6.0 U3.

0 Kudos