1Feuerdrache
Contributor
Contributor

Help Locating/Formatting Drives

To start off, I am fairly new to doing this, andI am encountering difficulties locating other disks. I am using two nvme ssds and a number of hdds connected to a lsi 9211. Only issue is it is only detecting a single nvme, so I can't setup any vms. For reference (I think I'm doing this right), I'm going to storage>New datastore>select device. Some of the drives are used if that helps. If anyone could direct me where I'm making a mistake, I'd appreciate it.  

0 Kudos
3 Replies
maksym007
Hot Shot
Hot Shot

The main question is what is your RAID Ctrl role here? And how did you configure it? 

is there a pass-through option? 

0 Kudos
TheBobkin
VMware Employee
VMware Employee

@1Feuerdrache, Note that you have posted this question in the vSAN sub-community but there is no clear indication you are trying to configure vSAN here - please confirm whether you are trying to create a VMFS datastore (as is shown in your attached image) or create a vSAN Disk-Group (which is not an option from the ESXi host UI).


Whether the devices are 'used' or not, they should be seen by ESXi in the Storage > Devices tab so clearly they are not detected - did you hot-add these? If so, you can try power-cycling the server.
If not, what devices does the out-of-band management (e.g. iDRAC, iLO) show? If you don't have such features then check in the controller menu/BIOS/boot options of the server on boot.

0 Kudos
1Feuerdrache
Contributor
Contributor

I am not extremely familiar with the process as a whole. I am trying to setup a data server for myself (potentially family), potentially run a game server, and (eventually) a web server. If it is not possible on on esxi, my stupidity is certainly showing. 

0 Kudos