dengxianzhi
Contributor
Contributor

ESXi 6.7 fail to enable vsan network vmkernel

Hi, all, I'm new to esxi and vsan

When I try enable vsan in vsphere client, the first is to add and vsan network vmkernel, but it failed to enable vsan service.

Can someone help me out?

pastedImage_2.png

pastedImage_3.png

And the log insystem : /var/log/vpxa.log

2018-10-03T09:35:18.346Z info vpxa[2188697] [Originator@6876 sub=Default opID=3eb294e7-2b60-4437-9bc8-68f7c3281bca-164015-auto-164019-h5c:70036552-33-ea] [VpxLRO] -- ERROR task-19 -- vsanSystem -- vim.host.VsanSystem.update: vmodl.fault.SystemError:

--> Result:

--> (vmodl.fault.SystemError) {

-->    faultCause = (vmodl.MethodFault) null,

-->    faultMessage = <unset>,

-->    reason = ""

-->    msg = "A general system error occurred: "

--> }

--> Args:

-->

--> Arg config:

--> (vim.vsan.host.ConfigInfo) {

-->    enabled = <unset>,

-->    hostSystem = <unset>,

-->    clusterInfo = (vim.vsan.host.ConfigInfo.ClusterInfo) null,

-->    storageInfo = (vim.vsan.host.ConfigInfo.StorageInfo) null,

-->    networkInfo = (vim.vsan.host.ConfigInfo.NetworkInfo) {

-->       port = (vim.vsan.host.ConfigInfo.NetworkInfo.PortConfig) [

-->          (vim.vsan.host.ConfigInfo.NetworkInfo.PortConfig) {

-->             ipConfig = (vim.vsan.host.IpConfig) null,

-->             device = "vmk1"

-->          }

-->       ]

-->    },

-->    faultDomainInfo = (vim.vsan.host.ConfigInfo.FaultDomainInfo) null

--> }

18 Replies
MJMSRI
Enthusiast
Enthusiast

Looks like its on the same vSwitch as the Management Network and VMKernel, best to segregate this off to its own Switch with different vmnics. Distributed Switch included with vSAN so could create a new vDS for vSAN and then bind the adapters to that then try to configure the vSAN VMK's on their own unique IP Subnet and VLAN.

0 Kudos
TheBobkin
VMware Employee
VMware Employee

Hello dengxianzhi​,

Welcome to vSAN.

Have you tested setting this via the Flash Web Client?

Have you tried setting this via direct connection to the host via CLI?

# esxcli vsan network ip add -i vmk1

MJMSRI - being on the same vSwitch *shouldn't* be problematic as they are using it's own vmk and not multihoming IPs etc., but yes, aim to set the NIC active/standby correctly and opposite for each traffic type if doing it this way.

Bob

0 Kudos
GreatWhiteTec
VMware Employee
VMware Employee

Is that the correct IP for that vmk? It looks like it is an APIPA address?

A+, DCSE, MCP, MCSA, MCSE, MCTS, MCITP, MCDBA, NCDA, NCIE-SAN, NCIE-BR, VCP4, VCP5, VCP5-DT, VCAP5-DCA _____________________ If you find this or any other answer useful please consider awarding points by marking the answer correct or helpful.
TheBobkin
VMware Employee
VMware Employee

Hello GreatWhiteTec​,

Well spotted - APIPA won't work for vSAN traffic and thus this should be changed before proceeding

Bob

0 Kudos
diegodco31
Leadership
Leadership

Hi

You need to configure one static ip or create reserve in the dhcp.

The following configuration is not supported: vCenter Server deployed on a vSAN 6.6 cluster that is using IP addresses from DHCP without reservations. You can use DHCP with reservations, because the assigned IP addresses are bound to the MAC addresses of VMkernel ports.

Designing the vSAN Network

Diego Oliveira LinkedIn: http://www.linkedin.com/in/dcodiego
0 Kudos
dengxianzhi
Contributor
Contributor

pastedImage_0.png

I create a new switch, but it still showed the same error,

Thanks

0 Kudos
TheBobkin
VMware Employee
VMware Employee

Hello dengxianzhi​,

Can you try configuring this via the CLI using the command I listed above on vmk1?

Whether this set correctly can be verified using:

# esxcli vsan network list

Asking this to rule out vCenter/Client issues vs Host/vSAN issues.

Bob

0 Kudos
dengxianzhi
Contributor
Contributor

Sorry, I'm new to vsphere, what do mean APIPA?
I used the static IPv4 settings

pastedImage_0.png

0 Kudos
dengxianzhi
Contributor
Contributor

pastedImage_0.png

It's empty

0 Kudos
TheBobkin
VMware Employee
VMware Employee

Hello dengxianzhi​,

Did you try enabling it first as I said?:

# esxcli vsan network ip add -i vmk1

Bob

0 Kudos
Daisukey1380
Contributor
Contributor

Hi

0 Kudos
TheBobkin
VMware Employee
VMware Employee

Hello Yammy,

There are a number of things that could cause inability to enable vSAN traffic and thus you shouldn't assume you have the *same* issue - OP here had multiple issues as you can see from the above thread and didn't clarify whether they were able to eventually perform this directly on the host after resolving some of their initial issues.

Thus I would advise reading the above comments and rule these causes out first (and of course rule out other potential causes like licensing, permissions etc.).

Bob

Daisukey1380
Contributor
Contributor

Hello, Bob

Thank you for your kind responce.

And I'm sorry for the lack of information on my first post.

I had taken below steps before my first post on this thread.

1. Separating vSwitch for vSAN traffic (as MJMSRI pointed).

    I made a vSS dedicated for vSAN traffic, other traffics uses other vDS.

2. Performing below command on the Host (as you said before).

   # esxcli vsan network ip add -i vmk2

3. Setting a static IP address (not APIPA) (as GreatWhiteTec and Oliveira said).

4. Checking vpxa.log and hostd.log.

    In vpxa.log, similar message was logged(attatched).

5. License is properly applied to the host.

I'm still seeing the issue after all of above steps.

If I should start another discussion, I'm willing to do so.

I'm so glad if I could have further advise..

Regards

yammy

0 Kudos
Daisukey1380
Contributor
Contributor

Hi,

I had a problem that resembles to yours, and finally I could set the vsan traffic on the vmkernel port.

At first time, I performed a clean install of ESXi 6.7 to the host. And encountered the problem.

None of actions resolved nor clarified the problem as my second post on this thread.

I once performed installation of ESXi 6.5 on the host, and then updated ESXi from 6.5 to 6.7.

Now I could enable the vsan traffic on the vmkernel port.

Hope this helps.

Regards

yammy

0 Kudos
TheBobkin
VMware Employee
VMware Employee

Hello Yammy,

Any chance you initially added the host to vCenter with administrator@vsphere.local or some other account than root?

I ask as the logs you posted keep stating 'Throw vim.fault.NoPermission' etc.

Bob

0 Kudos
Daisukey1380
Contributor
Contributor

Hello, Bob

When I initially added the ESXi host, I have seen that the blank for username was filled with "administrator@vsphere.local"(before I fill in the blank with "root").

I first deleted "administrator@vsphere.local", then entered "root" as username.

The host was successfully added.

About no permission error, I wonder if the username value was "null" at that time.

I attach why I thought such a thing from the log(though I cannot determine it is related to this issue or not..).

Regards

Yammy

0 Kudos
Hunnywell
Contributor
Contributor

I needed to edit this because after adding some additional hosts I ran into the same issue.

Something during the connection of vCenter to the ESXi host was not 100%.  I needed to disconnect the affected hosts and then ran the following PowerCLI command to force a reconnect:

$connectSpec = New-Object VMware.Vim.HostConnectSpec

$connectSpec.force = $true

$connectSpec.userName = 'root'

$connectSpec.password = 'SomethingHere'

foreach ($VMHost in @(Get-VMHost -State Disconnected))

{

    $connectSpec.hostName = $VMHost.name

    $VMHost.extensionData.ReconnectHost_Task($connectSpec,$null)

}

After reconnecting the host, everything worked great.  Hopefully this will also work for some of the affected people.

briamiva
Contributor
Contributor

Hello,

you can configure the vmkernel with the following command

esxcli vsan network ip set -i vmk1

0 Kudos