JonXXVIII
Contributor
Contributor

vRSLCM errors using UI - 2.1.0 Patch 2

Hi all,

Hoping you can help.. first time using vRSLCM and I'm having problems getting started.

I've followed the KB on install, upgraded to the latest 2.1.0 Patch 2 (Build 13273278) and then I've started to use it. I haven't added a vIDM at this point - was hoping to do that later. I'm using admin@localhost.

As an example of something that doesn't work - if I try to add a Source Control server (Content Management > Content Settings > Source Control Access)

vm1.png

vm2.png

If I look at the underlying request using dev tools, I can see I'm getting 403 forbidden back from the CMS API:

vm3.png

However, if I then take that request and use the API directly using postman / powershell with that same admin@localhost, I'm able to add the endpoint successfully, and it turns up in the UI:

vm4.png

The same thing is happening with other parts of the UI, examples:

  • Adding access key to Source Control endpoint
  • Enabling pipeline stubs
  • Adding vSphere template repo
  • Adding Content from e.g. vRO workflow

Has anyone seen this before / have any idea what I can try / where I can raise it?

I thought to try adding vIDM but wanted to see if I can use vRA's as I'm limited on resource - does anyone know if that's possible?

Thanks,

Jon

Tags (1)
0 Kudos
1 Reply
Noemie
Enthusiast
Enthusiast

Hello ,

I had the issue but with Gitlab tool, i  don't know if bitbucket work on the same way or not, but in my case,  i had to set again the access key ( token in gitlab ) and after that i have to give the rights permissions INSIDE Gitlab to give permission of lifecycle manager to push and get information insde my project.

I do'nt know if it's help or not.

Regards,

0 Kudos