VMware Cloud Community
levgoronshtein
Contributor
Contributor

vCD and vSAN

Hi All,

I am having a problem with vCD not working correctly with vSAN on two different clusters. Please see below the description:

vCenter

  • 1 DataCenter
    • Cluster01
      • vSAN01
    • Cluster02
      • vSAN02
    • 1 Storage Polices for both vSANs.

in vCD when we go and try to modify any VM that lives in vSAN01 it tries to write the changes for some reason to vSAN02 but if i try to make a change to a VM that lives on vSAN02 it works perfectly fine. If i disable vSAN02 datastore in vCD all works fine for any VM that resides in vSAN01.

Has anyone else seen this issue and if yes what has been done. Am i doing something wrong or do we need to always have different storage policies for different vSAN's and our tenants need pick the correct storage policy? kind of doesnt make sense as vCD should know where the VM resides and where to update it.

0 Kudos
8 Replies
paluszekd
VMware Employee
VMware Employee

Questions:

  1. How do you have your pVDC(s) setup? Is there one per cluster?
  2. What is your SPBM/storage policy setup? How many hosts are in each cluster?
  3. What version of vCD is this?

This is odd behavior.

0 Kudos
levgoronshtein
Contributor
Contributor

Hi Paluszekd,

See below:

  1. How do you have your pVDC(s) setup? Is there one per cluster?
    1. 1 Provider vCD for the whole thing.
  2. What is your SPBM/storage policy setup? How many hosts are in each cluster?
    1. 1 Policy for both vSANs
      1. first cluster has 12 Hosts
      2. second cluster has 4 hosts with additional 8 going in soon.
  3. What version of vCD is this?
    1. vCD is 9.1.0.7905680
0 Kudos
paluszekd
VMware Employee
VMware Employee

Just for giggles, could you try to setup a separate SBPM/storage policy for each respective cluster/vSANDatastore?

Also, have you opened a SR with GSS yet? I'd like to get them to look at this and see what they say, but this is not expected behavior.

0 Kudos
levgoronshtein
Contributor
Contributor

I have done at as well, had 2 different Storage Policies and had them tagged as well. This still didnt work so we reverted back to 1 storage policy now which produces the same result.

also i do have a ticket open for the past week with the vCD team. this only happens through vCD and if i do the work via vCenter it works fine.

0 Kudos
paluszekd
VMware Employee
VMware Employee

If you can DM me the case number, I'd like to take a look at it. Thanks!

0 Kudos
levgoronshtein
Contributor
Contributor

I have tried multiple times and not able too, i just get a redline and nothing happens. can i not just add it to this post?

0 Kudos
paluszekd
VMware Employee
VMware Employee

Sure.

0 Kudos
levgoronshtein
Contributor
Contributor

VMware Support Request 18955219210

0 Kudos