VMware Cloud Community
mani_
Contributor
Contributor

vCD 10.4 WebConsole not working (fresh install)

Hi,

even after installing a vcenter + vcloud twice now, i can't seem to get the remote console(neither web/via application) working on a fresh install of 10.4. When inspecting it in the browser i see the following error:

Unable to acquire WebMKS ticket Http failure response for https://<URL/hostname of vcloud>/api/vApp/vm-xyz/screen/action/acquireMksTicket: 500 Server Error

I am currently out of ideas on how to get this fixed as everything else is working fine. Maybe someone has encountered this before and got a hint for me.

0 Kudos
4 Replies
Ramsgaard
Contributor
Contributor

Have you set a public signed certificate on the VCD cell(s) that you have deployed? Try to tail /opt/vmware/vcloud-director/logs/console-proxy.log file on the cell and see what it says when opening a web console. 

0 Kudos
mani_
Contributor
Contributor

ty that was it actually, as it is only a test installation it was enough to upload its own self signed cert when configuring the public address. i thought it takes it automatically.

0 Kudos
moellerjot
Enthusiast
Enthusiast

Hi, 

the Webconsole moved to port 443.

https://docs.vmware.com/en/VMware-Cloud-Director/10.4/vcd_104_install.pdf

P:28

...
Starting with VMware Cloud Director 10.4, both the console proxy traffic and HTTPS
communications go over the default 443 port.
...

 

Best Regarts 

moellerj

0 Kudos
imthiachulu
Contributor
Contributor

Hello Mani,

The highest possibility is a missing/wrong public cert, can you please check that?

You can easily export your browser cert and import it, check this blog post on "how to" steps.

 

Thank You

Imthiyaz Cloud
0 Kudos