kushubham9
Enthusiast
Enthusiast

vCD 10.0 | First time login and configuration wizard

Jump to solution

Hi,

I have setup a vCD 10.0 instance and want to configure the system for the first time (Steps like adding system administrator/Connection a vCenter etc).

However, when I access the [vCD-FQDN], I see the provider login page all the time.

Is there any default user/password for first time configuration? How do I configure it?

0 Kudos
1 Solution

Accepted Solutions
paluszekd
VMware Employee
VMware Employee

Sorry, but did you use the "system-setup" command through the cell management tool after you utilized the .bin file?

View solution in original post

0 Kudos
10 Replies
paluszekd
VMware Employee
VMware Employee

Default is "admin" along with the password you set on deployment of the OVA (presuming you used the appliance).

0 Kudos
kushubham9
Enthusiast
Enthusiast

paluszekd​ I used binary and not OVA to setup vCloud director.

I even tried reset the password for the 'admin' user. But it says the user does not exist.

[root@vcd10 bin]# ./cell-management-tool recover-password --dbuser vcd --dbpassword vcd

Please enter the system administrator username whose password is to be changed: admin

Please enter the new password:

Reenter the password:

The user "admin" could not be found.

0 Kudos
paluszekd
VMware Employee
VMware Employee

And what about "administrator" account?

0 Kudos
kushubham9
Enthusiast
Enthusiast

Same,

[root@vcd10 bin]# ./cell-management-tool recover-password --dbuser vcd --dbpassword vcd

Please enter the system administrator username whose password is to be changed: administrator

Please enter the new password:

Reenter the password:

The user "administrator" could not be found.

Is there not any initial configuration wizard in vCD 10?

I remember to have created a system administrator user in 9.7!

0 Kudos
paluszekd
VMware Employee
VMware Employee

Sorry, but did you use the "system-setup" command through the cell management tool after you utilized the .bin file?

View solution in original post

0 Kudos
kushubham9
Enthusiast
Enthusiast

No I hadn't.

After I did this step, authentication is getting successful (in the provider view) but now I see a 'bootstrap-failure' error after login.

-------------

An error was encountered during initialization. This can be caused by issues such as accessing the application via an unsupported public URL or poor connectivity.

Redirect URL: [FQDN]/provider/bootstrap-failure?url=%2Fprovider%2F

-------------

0 Kudos
paluszekd
VMware Employee
VMware Employee

Use the IP. you will need to establish the endpoint URL along with the certificate.

0 Kudos
kushubham9
Enthusiast
Enthusiast

Thanks a lot! Smiley Happy

Works with the IP. I didn't get the other part, "you will need to establish the endpoint URL along with the certificate."

How to do this?

0 Kudos
paluszekd
VMware Employee
VMware Employee

Administration -> Settings: Public Addresses, click Edit:

pastedImage_0.png

0 Kudos
falanazi
Contributor
Contributor

run this command

./cell-management-tool system-setup --user admin --full-name "VCD System Administrator" \ --email vcd-admin@example.com --system-name VCD --installation-id 1

it will ask you to type the password.

0 Kudos