QuincySanders
Contributor
Contributor

vApp's intermittently wont start - Unable to deploy network...

Jump to solution

I have a catalog item that was published to be an identical copy. It has two vm's and an internal vApp network that is NATd and Firewalled. I'm an org admin, User A and User B are both vApp Authors. When User A deploys this item and tries to power it on, this is the error that's received:

Unable to deploy network "TLX Internal(urn:uuid:ba517443-bb68-43f6-b10a-bde8f8df8003)".

  1. com.vmware.ssdc.util.LMException: DV portgroup dvs.VCDVSTLX Internal-ba517443-bb68-43f6-b10a-bde8f8df8003 is not found in the inventory after creation

- com.vmware.ssdc.util.LMException: DV portgroup dvs.VCDVSTLX Internal-ba517443-bb68-43f6-b10a-bde8f8df8003 is not found in the inventory after creation

- DV portgroup dvs.VCDVSTLX Internal-ba517443-bb68-43f6-b10a-bde8f8df8003 is not found in the inventory after creation


If I, as an org admin, attempt to power this on, I get the same error message HOWEVER if I have  User A deploy this vApp and leave it in a powered off state, I CAN power it on successfully.


User B can deploy and power on this exact same vApp with no problem at all.



What gives?

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
IamTHEvilONE
Immortal
Immortal

Also, that KB is out of date.  I think the issue was fixed in 5.5.3 per this release note:

  • Attempts to power on a vApp sometimes fail with a distributed port group error
    When you attempt to power on a vApp, the operation sometimes fails with an error similar to the following.
    DV portgroup is not found in the inventory after creation.This issue is resolved in vCloud Director 5.5.3.

View solution in original post

0 Kudos
4 Replies
IamTHEvilONE
Immortal
Immortal

Are the users deploying to two different Org vDCs/vCenters?

Also is the Network Pool backing the person having a failure VXLAN based?

With VXLAN, we put a request for a new vWIRE to vShield/NSX.  After some time we poll vCenter to see if a Port Group exists of the name we requested to NSX/vShield.  If we wait too long, it'll fail.

What doesn't make sense is if the users are in the exact same Org vDC.  then the only thing changing is the User requesting the Power on and the time of day (busy factor).

Are you on an older build of vCloud Director?  I think what you are seeing is talked about in kb 2092685.

0 Kudos
IamTHEvilONE
Immortal
Immortal

Also, that KB is out of date.  I think the issue was fixed in 5.5.3 per this release note:

  • Attempts to power on a vApp sometimes fail with a distributed port group error
    When you attempt to power on a vApp, the operation sometimes fails with an error similar to the following.
    DV portgroup is not found in the inventory after creation.This issue is resolved in vCloud Director 5.5.3.

View solution in original post

0 Kudos
QuincySanders
Contributor
Contributor

Hi, thanks for the response, you are correct, this issue is a minor bug in 5.5.2 and updating to 5.5.3 resolved this issue.

0 Kudos
IamTHEvilONE
Immortal
Immortal

Good to know.  I talked to some people to get that KB article updates, so it shows that the fix is in 5.5.3 now as well.

If you can take a second to mark a reply as correct, it'll help others who search the forums/web for help (it puts the correct post nested in the original).

0 Kudos