VMware Cloud Community
basteku73
Enthusiast
Enthusiast

problem with installation of vslad agent on host

Hi again ...

I have another problem ... When I try to prepere a host I get an error ..

2010-09-10 09:11:30,069 | DEBUG | pool-preparehost-23-thread-2 | NfcLauncherClient | <== |

2010-09-10 09:11:30,069 | ERROR | pool-preparehost-23-thread-2 | NfcLauncherClient | NFC Error. Error executing arg = ExecBundle<host=10.10.0.51,bundle=/opt/vmware/cloud-director/agent/vslad-install-esx41-1.0.0.67.bin,hostKey=1,>. NfcServer = 10.10.0.51 |

com.vmware.ssdc.library.exceptions.ExecBundleException: Error occurred executing agent script "/opt/vmware/cloud-director/agent/vslad-install-esx41-1.0.0.67.bin" on host "10.10.0.51". - Multiple Exceptions follow: [com.vmware.ssdc.util.LMException: Unable to load module "dvfilter".]

at com.vmware.vcloud.val.nfc.internal.impl.AgentInstallManager._execBundle(AgentInstallManager.java:159)

I can see that module dvfilter is unable to load ... And I have no idea why ..

Please help me ..

Regards

Sebastian

Reply
0 Kudos
7 Replies
HanyM
Enthusiast
Enthusiast

Hi,

Has this host been prepared by a vCenter Lab Manager earlier?

Hany Michael

--

Blog: http://www.hypervizor.com

Twitter: http://www.twitter.com/hany_michael

*Hany Michael* -- Blog: http://www.hypervizor.com Twitter: http://www.twitter.com/hany_michael
Reply
0 Kudos
basteku73
Enthusiast
Enthusiast

No .. it hasn't. This host has been prepered by vCloud Director earlier ...

I had to reinstall vCD ...

Maybe I have to reinstall this module.

Regards

Bastek

Reply
0 Kudos
HanyM
Enthusiast
Enthusiast

I remember I had the same error before but if I recall the host was prepared by Lab Manager (or may be a different beta version of vCD).

You can try to manually uninstall the vslad agent first and then prepare the host back again from the vCD GUI.

To uninstall the agent manually use this command:

/opt/vmware/uninstallers/vslad-uninstall.sh

Alternatively, you can use the CloudCleaner tool (use it with caution though):

http://www.hypervizor.com/2010/09/tool-cloudcleaner-v2-3/

Hope this helps.

Regards,

Hany Michael

--

Blog: http://www.hypervizor.com

Twitter: http://www.twitter.com/hany_michael

*Hany Michael* -- Blog: http://www.hypervizor.com Twitter: http://www.twitter.com/hany_michael
Reply
0 Kudos
basteku73
Enthusiast
Enthusiast

Ok thank You for Your sugestion ..

In fact I uninstalled the agent earlier. I had a messege that the agent is installed, so I uninstalled it and I tried to prepere host again ... and I always get this error.

But thanks for the tool. Try it.

Regard

Bastek

Reply
0 Kudos
admin
Immortal
Immortal

How did you uninstall the agent? Did you ssh into your host and do it from the command line or did you try to somehow do it from the vCloud Director GUI? Generally, I use this command from the shell of the host.

/opt/vmware/uninstallers/vslad-uninstall.sh

Reply
0 Kudos
basteku73
Enthusiast
Enthusiast

I ssh into my host and I uninstalled it from command line ... but in fact I found the reason ... the reason of my problems was that I ran a chargeback script (probably it was chargeback 1.5 beta version) witch had cleaned some tables of my cloud database.

Thanks anyway Smiley Happy

Regards

Sebastian

Reply
0 Kudos
virtualizatio12
VMware Employee
VMware Employee

I have put a post as well on how to install and uninstall the vCloud agent on both ESXi 5 & ESXi 4 which might be helpful in similar situations:

Manually installing the vCloud Director Agent on ESXi 5 / vSphere 5

Hope this help!

Regards,

Eiad Al-Aqqad

B: http://www.VirtualizationTeam.com

B: http://www.TSMGuru.com

Reply
0 Kudos