conraddel
Contributor
Contributor

VCLOUD Director 5.1 VCDNI network issue

Hi there all

We are running into an issue with VCD5.1 and VCDNI backed network pools.Basically VM's in organization networks backed by VCDNI network pools cannot communicate with each other at all and if there is a routed edge connected to the org network then the VM's cannot communicate with the inside interface of the edge.

We have tested the layer2 transport VLAN between the hosts and there is no problem there. Even if the VM's in question are pinned to the same host the problem still occurs.

We have confirmed that the Vshield manager is creating the required dvportgroups. Has anybody else seen this as yet ?

0 Kudos
4 Replies
mreferre
Champion
Champion

Most of the time this is a VLAN misconfiguration on the hosts. Sometimes I have seen this happening when the MTU size isn't enlarged to accomodate the VCDNI frame (depending on the switch configuration a bigger frame can either be fragmented or discarded). 

Massimo Re Ferre' VMware vCloud Architect twitter.com/mreferre www.it20.info
0 Kudos
_morpheus_
Expert
Expert

Try unpreparing and repreparing the hosts, and then stop/start the affected vApps

conraddel
Contributor
Contributor

Hi there

We did try and unprepare/re prepare the hosts without success. We did manage to fix the problem by:

1. Unprepare hosts

2. Reboot hosts

3. Prepare hosts

After that the VCDNI networks started working 100%. Is this some type of bug in the initial prepare workflow ?

0 Kudos
_morpheus_
Expert
Expert

I suspect initial preparation wasn't done correctly

0 Kudos