OmarHermannsson
Contributor
Contributor

Trying to migrate VMs between resrouce pools but having terribly unreliable results

Jump to solution

We are trying to use the API to migrate VMs between resource pools in the same PVDC using migrateVms, since this feature has been removed from the GUI.

We submit the POST request without any issues and it returns among other things the link to the task that we query to get the results of migration task

The results we are getting is that maybe 10-20% of the VMs are migrated without issues, most of them return a 500: Internal Server Error(and no good indication as to what the issue is) and are not migrated and lastly, the worst result is that perhaps around 5% will return a Success status in the task, vCloud will believe it's migrated the VM but it's still sitting in it's old resource pool. In this last case, vCloud will be unable to operate on the VM until we manually move it to the destination resource pool through vCenter.

Does anyone here have experience with using this API call to move between resource pools? Any ideas what might be the problem. Perhaps these issues are the reason that this feature was removed from the GUI? 

In this case we are running vCloud 10.0 with vCenter 6.7.0.

0 Kudos
1 Solution

Accepted Solutions
DjinjiRinji
Enthusiast
Enthusiast

Do you have elasticity configured, storage and networks shared between pools?

https://docs.vmware.com/en/VMware-Cloud-Director/9.7/com.vmware.vcloud.admin.doc/GUID-2CE6C061-97FD-...

Are to specifying ResourcePoolRef in the API call?

https://code.vmware.com/apis/722/vmware-cloud-director/doc/doc/types/MigrateParamsType.html

 

Inconstancies in DB can happen. Is the ResourcePoolRef correct in VCD DB and VC DB?

 

Kindly mark as solved if your questions are answered.
>>>>>
Guillermo R
LinkedIn: https://www.linkedin.com/in/gramallo
Web: http://bakingclouds.com/

View solution in original post

0 Kudos
2 Replies
DjinjiRinji
Enthusiast
Enthusiast

Do you have elasticity configured, storage and networks shared between pools?

https://docs.vmware.com/en/VMware-Cloud-Director/9.7/com.vmware.vcloud.admin.doc/GUID-2CE6C061-97FD-...

Are to specifying ResourcePoolRef in the API call?

https://code.vmware.com/apis/722/vmware-cloud-director/doc/doc/types/MigrateParamsType.html

 

Inconstancies in DB can happen. Is the ResourcePoolRef correct in VCD DB and VC DB?

 

Kindly mark as solved if your questions are answered.
>>>>>
Guillermo R
LinkedIn: https://www.linkedin.com/in/gramallo
Web: http://bakingclouds.com/

View solution in original post

0 Kudos
OmarHermannsson
Contributor
Contributor

Thanks for the response DjinjiRinji. After contacting wmare support we found that the ResourcePool refs where missing in most cases, and in some cases it was a bug happening with suspended vms, that will be fixed in the next version. After applying a database fix and shutting down the suspended VMs we got things moving reliably.

0 Kudos