Anjani_Kumar
Commander
Commander

The operation failed because no suitable resource was found. Hub "Resources" doesn't have enough "*" storage: required - 60000 MB, available - 0 MB.

Jump to solution

Hello All,

vCD : 5.5.1

Today i am facing an issue with my vcd where i cant deploy the new vapp in our environment.

What i checked and made changes.

First i thought its an storage issue. but i have 18.84 TB storage available already out of 44 TB .

Second i change the threshold to minimum of the datastore.

Third i recreated the storage policy but not helpful.

Fourth i added a new storage policy for a different datastore and the vm deployed on it succesfully.

So still i am figuring out what is the correct issue there.

Please consider marking this answer "correct" or "helpful" if you found it useful. Anjani Kumar | VMware vExpert 2014-2015-2016 | Infrastructure Specialist Twitter : @anjaniyadav85 Website : http://www.Vmwareminds.com
Tags (2)
0 Kudos
1 Solution

Accepted Solutions
Anjani_Kumar
Commander
Commander

Some things are super funny with the vmware.

Thanks IamTHEvilONE‌ & ccinatl

Today i fixed the issue from my self. Dont know what was wrong. but i removed old storage profile tags etc from vcloud director and vsphere itself. created a new one. and now its working superawesome.

I forgot to tell you the reason. as i suspect : I created the storage profile 1 year ago and till that date the datastore frequently updated with the size and the name both. i added that storage profile 2 days ago . may be thats the reason but not anymore.

Cheers. Smiley Happy

Please consider marking this answer "correct" or "helpful" if you found it useful. Anjani Kumar | VMware vExpert 2014-2015-2016 | Infrastructure Specialist Twitter : @anjaniyadav85 Website : http://www.Vmwareminds.com

View solution in original post

0 Kudos
14 Replies
IamTHEvilONE
Immortal
Immortal

Is that a storage cluster?  If so, how large are the Datastores inside of it?  Do any have at least 310GB Free? (Red threshold of 250 + 60 GB required based on the error state).

I also need to know if Storage DRS is turned on.  If so, vCloud Director doesn't determine initial placement.  we send a definition of the VM to vCenter and get a response for compatible datastores.

Anjani_Kumar
Commander
Commander

Thanks IamTHEvilONE

I was expecting you for helping me out..

Well situation is I dont have sotrage Cluster enabled. Only datastores are playing around with.


Yeah. one thing i have to share . We assigned a separate datastore to each org vdc in our environment. Now the Datastore already part of the production and having 30 TB full. and now we have to use the same datastore and migrate those vms in to the org vdc created for it.

(e.g. Like we have a Team called "ABCaround 250 vms are for them and hosting on the same 44 TB datastore occupying around 30 TB of datastore. now we created a org vdc in same environment and add that datastore 44 TB datstore in to it. some vms are thin provisioned. now we cant build our first vapp to test the environment.even cant migrate any vms from that team.)

Please consider marking this answer "correct" or "helpful" if you found it useful. Anjani Kumar | VMware vExpert 2014-2015-2016 | Infrastructure Specialist Twitter : @anjaniyadav85 Website : http://www.Vmwareminds.com
0 Kudos
IamTHEvilONE
Immortal
Immortal

The only other limiting factor I can think of is the Organization vDC's Storage Policy doesn't have enough space left in it.

Here is at least a starting point, may I have a screen capture of:

1. Manage & Monitor > Organization vDCs > Double click the one where deployment fails > Storage Policies tab > I need to see all policies listed here

2. Based on the error it seems that we need 60 GB of space to be free, can you just validate that is correct from the source vApp/VMs you are deploying?

Anjani_Kumar
Commander
Commander

Sure. find the attachment.

The policy client services is the impacted one. SCDemo works fine(Tested that SP for making it sure).

We have enough storage available on our environment in client service datastore .

Pic1.jpg

See the Client services datastore.

01st.jpg

Please consider marking this answer "correct" or "helpful" if you found it useful. Anjani Kumar | VMware vExpert 2014-2015-2016 | Infrastructure Specialist Twitter : @anjaniyadav85 Website : http://www.Vmwareminds.com
0 Kudos
Anjani_Kumar
Commander
Commander

Yeah one more thing to share. till now i was creating orgvdc with the scratched datastore which was start using by vcloud only.

but this is the org vdc i am using a already being used datastore. Hope this is not causing the issue. (just afraid if it is the reason ?)

Please consider marking this answer "correct" or "helpful" if you found it useful. Anjani Kumar | VMware vExpert 2014-2015-2016 | Infrastructure Specialist Twitter : @anjaniyadav85 Website : http://www.Vmwareminds.com
0 Kudos
IamTHEvilONE
Immortal
Immortal

Okay, so it seems fine here from an allocation perspective.

Next 2 Screen captures:

1. Manage & Monitor > Storage Policies > Screen capture Client Services

2. Manage & Monitor > Provider vDCs > Double click the provider vDC backing the Org vDC > Storage Policies > screen capture the storage policies here.

Anjani_Kumar
Commander
Commander

sorry for delay.

PFA. 01.jpg02.jpg

Please consider marking this answer "correct" or "helpful" if you found it useful. Anjani Kumar | VMware vExpert 2014-2015-2016 | Infrastructure Specialist Twitter : @anjaniyadav85 Website : http://www.Vmwareminds.com
0 Kudos
IamTHEvilONE
Immortal
Immortal

Unless the Datastore is disabled in the Datastore list (managed & monitor), there is no immediate reason for this error state to happen that I can tell.

The next test to do, would be to reduce the Red Threshold on this specific Datastore by 70GB and then attempt to provision the vApp again.  If this works, there is something funny with how the threshold is being applied in this situation.

0 Kudos
Anjani_Kumar
Commander
Commander

I did below now.

1. reduce the red and yellow threshold to 70 and 150 GB.

2. tried to create a small vapp with 30 GIG of space. 

No luck.

Was just suspecting as this is the biggest datastore in our environment 44 TB. Is their any limitation for the max size of datastore support.  Also this datastore extended multiple times till now.

Also i find below URL to run SQL query .Does this will help ?

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=206268...

Please consider marking this answer "correct" or "helpful" if you found it useful. Anjani Kumar | VMware vExpert 2014-2015-2016 | Infrastructure Specialist Twitter : @anjaniyadav85 Website : http://www.Vmwareminds.com
0 Kudos
IamTHEvilONE
Immortal
Immortal

yeah, the query could help in case the data is stored incorrectly.

I'm not aware of a limit on a given Datastore, which is capped at the database level by the column type (which I think is big int).

0 Kudos
Anjani_Kumar
Commander
Commander

Didnt find anything specific in the query result. today i again investigate the storage as i thought there must be something wrong with the storage. as i can see there are multiple extents in to that.

They are like 2 TB in starting(may be upgraded to vmfs5) and 10 TB later.

I also opened a SR in vmware to see if they can help .

storage.jpg

Please consider marking this answer "correct" or "helpful" if you found it useful. Anjani Kumar | VMware vExpert 2014-2015-2016 | Infrastructure Specialist Twitter : @anjaniyadav85 Website : http://www.Vmwareminds.com
0 Kudos
ccinatl
Enthusiast
Enthusiast

we had a similar issue.  not exactly what you are describing, but close.  you may want to check via vcenter web client that your storage profile contains the tag referencing your volume.  It looked correct in the normal vSphere client but in the web client, it was not there.

Anjani_Kumar
Commander
Commander

i created the tags and profile twice from webclient only. even i cant see those profile from the vsphere client. but visible in vsphere client.

Please consider marking this answer "correct" or "helpful" if you found it useful. Anjani Kumar | VMware vExpert 2014-2015-2016 | Infrastructure Specialist Twitter : @anjaniyadav85 Website : http://www.Vmwareminds.com
0 Kudos
Anjani_Kumar
Commander
Commander

Some things are super funny with the vmware.

Thanks IamTHEvilONE‌ & ccinatl

Today i fixed the issue from my self. Dont know what was wrong. but i removed old storage profile tags etc from vcloud director and vsphere itself. created a new one. and now its working superawesome.

I forgot to tell you the reason. as i suspect : I created the storage profile 1 year ago and till that date the datastore frequently updated with the size and the name both. i added that storage profile 2 days ago . may be thats the reason but not anymore.

Cheers. Smiley Happy

Please consider marking this answer "correct" or "helpful" if you found it useful. Anjani Kumar | VMware vExpert 2014-2015-2016 | Infrastructure Specialist Twitter : @anjaniyadav85 Website : http://www.Vmwareminds.com
0 Kudos