rakhtar
Contributor
Contributor

Customization fails in Windows 7

Hi,

Windows 7 Pro is syspreped with command "sysprep /generalize /oobe /shutdown" and added to catalog with updated vmtools.

When I am deploying new VM from template, customization fails with error message.

"Could not find network adapters as specified by guest customization configuration Log files is at 'c:\windows\TEMP\customize-guest.log'

Even when I login to VM network card E1000 is present.

Thanks

0 Kudos
4 Replies
IamTHEvilONE
Immortal
Immortal

can you provide the log, and validate the ethernet card type in the VMX?

Best Regards,

Jon Hemming

0 Kudos
rakhtar
Contributor
Contributor

For Windows  7 and Windows 2008, Is VCD customizing or I need to prepare sysprep.xml file and copy to c:\windows\system32\sysprep ?

- Customization-guest.log attached.

- ethernet0.virtualDev = "e1000"

Thanks

0 Kudos
IMMatt
Enthusiast
Enthusiast

I find that sysprep on Windows 2008 R2 and Windows 7 is prone to failure.  (Note that Microsoft doesn't support sysprep if applications are installed)

I recommend that you let it do guest customization without sysprep (Turn off the "Change SID" checkbox on the guest customization tab)....  Guest customization (computer name, networking) happens much faster without sysprep.

For those that are worried about SID duplication, read this: http://blogs.technet.com/b/markrussinovich/archive/2009/11/03/3291024.aspx

0 Kudos
rakhtar
Contributor
Contributor

When I add windows 7 VM from template, it can't join to domain, even I entered domain name and account credential in Organizatio / Administraton / Guest Personalization.

When I right click VM and check properties, under guest customization "Join domain" section is disabled. unattend.xml file that is copied from vcd during guest customization also have domain section commect out.

Any idea why I can't join windows 2003 and windows 7 VM to domain,

Thanks

0 Kudos