Devilish
Contributor
Contributor

Cloud Network Isolation VCD-NI doenst work across hosts

Jump to solution

Hi everyone

I am hoping someone that already using  Network isolation-backed Network pool can help me here.

i have opened a case recently with VMware and was kinda shocked of what i was told since it worked fine across hosts for me with 1.0 and during the 1.5 beta of vCloud director

here is the problem.

i have one external network on VLAN 207

i created one networkpool for an organization using VCD-NI   where 2 is the number of isolated network and VLAN Id of 1

when i create internal or routed organization network VM cant communicate if they reside on different hosts in the cluster

if it happens that the VMs or the edge appliance "Router" is on the same hosts then i have no issue pinging the other VMs or the routing appliance to reach the external network .

VMware is telling me now that i have to create VLAN ID 1 which is really optional according to all the docs out there.  and i had it work before .

your help is highly appreciated

thanks

Maher

0 Kudos
1 Solution

Accepted Solutions
_morpheus_
Expert
Expert

If you create a VCDNI network pool and use a VLAN ID for the pool, then the VLAN must exist in your switch. If you don't want to use a VLAN ID then create a new VCDNI pool and leave the VLAN ID field blank.

View solution in original post

0 Kudos
9 Replies
baskam
Contributor
Contributor

I’m out of the office and on vacation the week of 11/28/2011, and will be back in the office Tuesday 12/06/2011.

If you require immediate assistance please contact support at lw-support@logicworks.net

Thanks,

Baska Walsh,

SR NOC Engineer

Logicworks

0 Kudos
guitzer
Contributor
Contributor

Dear Sender:

I will be Out Of Office by today Nov. 25th, 2011. I will get back to you ASAP when return.

Regards

0 Kudos
_morpheus_
Expert
Expert

If you create a VCDNI network pool and use a VLAN ID for the pool, then the VLAN must exist in your switch. If you don't want to use a VLAN ID then create a new VCDNI pool and leave the VLAN ID field blank.

View solution in original post

0 Kudos
JayhawkEric
Expert
Expert

Maher,

As morpheus stated the VLAN must exist but it must be enabled as well.  Most LAN admins disable VLAN 1 per security standards.  This may be why it isn't working for you.

We use the same setup as you are describing but with 2 valid VLAN's and it works properly.

Eric

VCP5-DV twitter - @ericblee6 blog - http://vEric.me
Devilish
Contributor
Contributor

Thanks guys that's exactly what I did The hosts have access to two VLANs one I used when I created the VCDNI network pool and one i used as my external network .

Maher

0 Kudos
sbrad001
Contributor
Contributor

I'm having this problem with communication across hosts... but I dont have a VLAN tag associated with my VCD-NI pool.... any ideas?

0 Kudos
JayhawkEric
Expert
Expert

I couldn't get it to work in my testing without assigning a VLAN to the VCD-NI pool.  I think it didn't work for us b/c I think it using VLAN ID 1 (default) if you do not assign one to it and we administratively disable VLAN 1 within our switches.  I'm not 100% sure this is why though.

VCP5-DV twitter - @ericblee6 blog - http://vEric.me
0 Kudos
sbrad001
Contributor
Contributor

That's interesting... so is there an undocumented requirement that VCD-NI requires the presense of a default vlan if no VLAN ID is specified?

0 Kudos
_morpheus_
Expert
Expert

VCDNI requires layer-2 connectivity across all hosts in the cluster that are connected to the dvSwitch. The lack of a VLAN tag on a portgroup doesn't mean the portgroup has no VLAN, it means that you're using the default VLAN, which still needs to be available to all hosts in the cluster.

0 Kudos