vmotion without shared storage


Actually i am confused with the concept of enhanced vmotion.What my understanding is that enhanced vmotion is used for situation where no shared storage available and it will do vmotion same like the normal vmotion without powered off.But recently we had a POC where servers are without shared storage and the servers used are different compatibility.So first we enabled EVC in the cluster since both hosts are of different cpu.and when i tried to do vmotion from web client and selected change host it was not showing the destination host to move.i can see the host where the vm is residing.Same when i tried to change the datastore.But when i selected change both host and datastore its showing the both hosts and when i initiated that it got stuck and failed after some time showing check vmotion network error in the web client and when checked progress of the vmotion from windows client its showing stuck at 29% showing migrating active state and got failed.But when i tried to powered off the vm and do the vmotion with change both host and datastore its migrating .

so in the case of hosts without shared storage whether we need to poweroff the vm and do the migration?

when we selected for changing the host and changing the datastore option separately why we are not able to see the host and datastore.But they appear when we selected to move both host and datastore at same time?

in our setup we had a standard switch which is carrying the management traffic to the vcenter connected to switch1  and distributed switch carrying the vm network and vmotion network connected to switch 2.

when i tried to give the same management ip range 172.19.19.x in the vmkernel port for the host 1 connected to distributed switch.i am able to set the ip.But when i tried to give same ip range in the vmkernel port of the host2 from the distributed switch its not getting set showing the setting got reverted back since it caused host management to become unreachable.I dont understand for both the host same configuration but why for the second host i am not able to the set the vmkernel finally i used some other ip range for the vmkernel port and did the above vmotion metioned.

can anyone please help on this ?

thanks in advance


0 Kudos
2 Replies

Did you ever find out what was going on here?

The reason why you can't just change the CPU resources when doing a vMotion without shared storage is because the VM wouldn't be able to read it's configuration files (vmx/vmdk/etc..) if those files were stored locally on a Datastore that isn't on the same ESXi host as where you are trying to vMotion the new VM to.

Think of it like this, how could the VM be able to read from its disks (vmdk) when it is stored locally on ESXi-1, when the VM itself would theoretically be living on ESXi-2 without any shared storage. The VM would have no connection to its disk files without the integration of shared storage.

I have a similar setup, no shared storage. When doing a vMotion of a very large VM ( ~ 6TB) the vMotion fails at 29% and I would have to think its somewhere with the network but curious if you ever figured out a workaround

0 Kudos
Hot Shot
Hot Shot

You can't vMotion a virtual machine to another host without shared storage on a singular option. You will have to select "Migrate hosts and storage". This should also be possible to do with a poweredOn VM. We do this stuff on a daily basis.

Also, you can't use the exact same IP on the VMkernel of both hosts, but I'm sure you have configured different IP adresses.

This looks to me that either you don't have the correct IP on the VMkernel, or that it's beeing routed and a ACL is shutting it down.

You should be able to find out what is wrong in the log file : /var/log/hostd.log

Could you test it again and provide us with some logs from the destination and source host from the above log file?

Visit my blog at!
0 Kudos