cruzenbye
Contributor
Contributor

vcenter server unable to find a master VSphere HA agent in cluster...

Last night I tried upgrading to VCenter 5.1 and had problems after the install where I could not log in.  Being late, I failed back to a snapshot version of my VCenter server taken just prior to the upgrade.  After I was able to back into VCenter all my hosts, clusters and VM's were available.   But my clusters are all erroring with VCenter Server unable to find a master VShpere HA agent in cluster.  Each host under the cluster has an error:  VSphere HA agent for the host has an error:  The VShpere HA agent is not reachable from VCenter Server.

Under vCenter advanced settings for SSL, if I check the vCenter requires verified host SSL certs, there are no servers showing up in hosts window.

Being a production environment, I'm hesitant to remove the hosts from vcenter, even in disconnect mode, without some assurance that I'm not going to lose my hosts and I'm going to lose my guests or not be able to bring the host back into an HA environment.


7 Replies
JimKnopf99
Commander
Commander

Hi,

did you try to disable HA and then enable it on your cluster again?

Everything is running except HA?

Frank

If you find this information useful, please award points for "correct" or "helpful".
cruzenbye
Contributor
Contributor

I have tried the following:

1.  Disabled the Host - Remove the host - then reconnect the host to the cluster.  Issue remains

2.  Disabled HA on the cluster.  Then re-enabled HA on the cluster.  Issue returns.

The cluster errors with:  vCenter Server is unable to find a master HA agent in Cluster....

The Host errors with:   vSphere HA agent for the host has an error:  vSphere HA agent cannot be correctly installed or configured.  vSphere HA cannot be configured on this host because the SSL thumbprint has not been verified.  Check that vCenter Server is configured to verify SSL thumbprints and that the thumbprint for this host has been verified.

When I go into the vCenter Server settings for the SSL, and enable the checking for verified ssl certs, there are no servers listed for me to verify the thumbprints.

0 Kudos
Suma309
VMware Employee
VMware Employee

Is there any update on this issue?

0 Kudos
runalongrh
Contributor
Contributor

By disabling VSphere HA on the cluster and then enabling it my issue went away.

azlans27
Enthusiast
Enthusiast

Disconnect and reconnect host fix my issue.

0 Kudos
PatrickC650
Contributor
Contributor

Thanks Frank, this helped me out with my issue.

0 Kudos
padduz
Contributor
Contributor

Thanks. It worked

0 Kudos