alvaropedroni
Enthusiast
Enthusiast

vcenter 7u3e default vm compatibility block version

Jump to solution

Hello.

 

On vcenter 7 is there the possibility to block the virtual hardware version compatibility to version 6.7u2?

The menu allows you to select up to version 7.0u2, but I have to block it on 6.7u2.

The new menus of 7 allow you to set the version but only as a recommendation for new VMs.

thanks

 

 

 

0 Kudos
1 Solution

Accepted Solutions
lamw
Community Manager
Community Manager

Yes. In vSphere 7.0 Update 2, a new API was released that allows you to configure the maximum supported vHW version. I'll do a blog post later on this topic when I get a chance but you can use the following PowerCLI snippet or other vSphere SDK Client if you prefer

$cluster = Get-Cluster Supermicro-Cluster
$spec = New-Object VMware.Vim.ComputeResourceConfigSpec
$spec.MaximumHardwareVersionKey = "vmx-15"
$cluster.ExtensionData.ReconfigureComputeResource_Task($spec,$true)

 

View solution in original post

0 Kudos
2 Replies
lamw
Community Manager
Community Manager

Yes. In vSphere 7.0 Update 2, a new API was released that allows you to configure the maximum supported vHW version. I'll do a blog post later on this topic when I get a chance but you can use the following PowerCLI snippet or other vSphere SDK Client if you prefer

$cluster = Get-Cluster Supermicro-Cluster
$spec = New-Object VMware.Vim.ComputeResourceConfigSpec
$spec.MaximumHardwareVersionKey = "vmx-15"
$cluster.ExtensionData.ReconfigureComputeResource_Task($spec,$true)

 

0 Kudos
alvaropedroni
Enthusiast
Enthusiast

hello

working perfect

 

thanks for support

0 Kudos