Highlighted
Contributor
Contributor

vSphere Web Client integration plugin problems in Windows 8.1

I don't know whether anybody else have come across this:

When you access the vSphere Web Client on Windows 8.1 -

1)Using Google Chrome in Desktop Mode, the web integration plugin works fine and you can authenticate with your current AD user account and launch the remote console as well.  (This will probably be the default for a lot of users, which is fine and hence the absence of related topics on Google Search)

As soon as you switch Chrome over to Windows 8 mode, the plugin is not recognised as installed (Option to use local user authentication is greyed out) and prompts you to download.  The remote console option within the web client also prompts for an installation of the plugin.

I don't think this is necessarily a Vmware or Google problem, because...

2)Using IE11 in either Windows 8 mode or Desktop mode, the plugin is not recognised as installed (Option to use local user authentication is greyed out).  When you change IE11 back to IE9 compatibility, the option to log in is available, but when ticked, does not pick up your username.

As I said, I don't know whether anybody else picked up on this and would like to hear your views.  It might just be a very early bug on Windows 8.1 and my early suspicions is that it has something to do with software permissions and UAC in Windows 8.1...

Any advice would be appreciated.

17 Replies
Highlighted
Contributor
Contributor

Web client on IE11 is not working. we should use chrome or Mozilla.

0 Kudos
Highlighted
Contributor
Contributor

The vSphere Web Client on IE 11/Win8.1 works in that you can explicitly log on/etc. (I don't use pass-through) and manage things but the remote console does not work. As stated the option to launch or install the client integration plug-in is greyed out.

So I installed Chrome and that does work as far as launching the console in a tab but the Send Ctrl-Alt-Del button does not appear to do anything. Black screen.

If I click the Full Screen button, then it jumps to my main monitor (regardless of where I have Chrome open--I have three monitors) and does work in full screen. But I cannot move that so if I do need to use the console, I have to think ahead.

On the IE 11 support--it is just VMWare not being able to keep up...I had to deal with the same thing a year ago when Windows 8 came out. That was with the full client and once we got to a certain level of vSphere it worked again.

This is on vSphere 5.1.832030 BTW.

0 Kudos
Highlighted
Contributor
Contributor

Aloha~

Got it to work.

1. Run As Admin - Uninstall Client Integration tools.

2. Run As Admin - Install Client Integration tools ( changed directory name to just "plugin" for good measure)

3. Run As Admin - IE 11.

4. Open Vshpere Web Client page.
5. (for me to get to pluggin, I right click to create from OVF file) Gives you a pop up window asking for permission within 10 seconds, see attached.
Running As Admin gives you this.PNG

Mahalo~

0 Kudos
Highlighted
Contributor
Contributor

I had similar problems.

VMWare Version 5.5.

Windows 8.1 and Windows 10, Server 2012 and Server 2008R2, Chrome and IE11

Solved my problem as following:

Installed plugin (as admin).

Start Browser as admin (right click task bar icon, right click on browser name and select start as admin).

The first time you attempt to use the plugin the browser will prompt you that plugin is blocked. You need to "allow" the plugin.

in chrome this sometime appears in the url line as a battery like icon with a red X - click on the icon to change settings  = enable the plugin.

From here on, you should be able to start the browser normally and still get access to the plugin

0 Kudos
Highlighted
Immortal
Immortal

Hi,

we had the same issue. The vSphere Integration plugin was installed but was greyed out in the IE11 under Windows 7, 8, 8.1, Windows Server 2008R2 and Windows Server 2012R2.

The User runs also the vSphere Web Client under Citrix XenApp 6.5.

So we implement the Internet Explorer 11 (IE11) Enterprise Mode and run the website of the web client in this mode and now it works.

This Link can help to understand the Internet Explorer 11 Enterprise mode.

https://blogs.msdn.com/b/ie/archive/2014/04/02/stay-up-to-date-with-enterprise-mode-for-internet-exp...

I hope it solves your problem.

Greetings

0 Kudos
Highlighted
Contributor
Contributor

I have noticed in IE 10 on Windows 7 that the plugin works and you can login with windows session credentials when IE is first opened. If the web client idles out and goes back to the login, you cannot use the windows session to log back in, and the prompt for downloading the plugin reappears. Closing all IE windows and opening the web client again will then work as intended again, until you idle out again. Very annoying when working on multiple tasks.

Has anyone else noticed this? Perhaps I will try Chrome to see if it happens there.

0 Kudos
Highlighted
Contributor
Contributor

Hi,

Please add vcenter FQDN address to "Local Internet" zone in security settings of Internet Expolrer.

In my case it's working with VMware vCenter 6.0 on Windows server 2012 R2.

VC6.JPG

Highlighted
Hot Shot
Hot Shot

Yes, the web client and integration plugin from vSphere 6 seems to work much better with Internet Explorer 11.  I didn't even have to add our vCenter site to the local intranet zone.

0 Kudos
Highlighted
Enthusiast
Enthusiast

Confirmed to fix the issue.

We use Windows Server 2012 with IE11 and the vShere Integration Plugin will be enabled as long as the vCenter Server v6 FQDN is registered in the browser as explained by VitaliyR:

"Please add vcenter FQDN address to "Local Internet" zone in security settings of Internet Expolrer."

Thanks for sharing the information here.

Highlighted
Enthusiast
Enthusiast

I had installed the plug-in as administrator, and that allowed Chrome to work. Firefox appears to load and give the option for Windows session auth, but the user name field is not populated like it is with Chrome/IE and if I click Login, it just sits there with the barber poll doing nothing.

IE would ask if I wanted to load the app, but would always display the "Download client" link UNTIL I added the vCenter FQDN to the Trusted Sites list. I even added it to the Local Intranet site list and that did nothing.  Only the Trusted Sites worked. Now my domain credentials are passed through and are working perfectly in IE and Chrome.

Thanks!

My lab:

Windows 7 Pro SP1

IE v11.0.9600.18163

Firefox 43.0.4

Chrome 47.0.2526.111m

vSphere Web Client 6.0.0 Build 2997665

vCenter 6.0.0 Build 3018523

0 Kudos
Highlighted
Enthusiast
Enthusiast

Hi,

I am switching from W8.1 to W10

On w8.1 I use vSphereClient. Didn't try web client.

1. on W10 there is no go for the Client (Desktop install) - an error during installation pop up (didn't check if the fix is available)

2. would like to go with the web client.

I am accessing vCenter web page then hit Log in to vSphere Web Client and get: the page could not be displayed.

I tried what is suggested above : added the FQDN of vcenter to  Local Intranet and Trusted zones. Not helps.

People talking about PLUGIN... Please point me to the download link for the plugin.

vSphere in use - 5.1

Thanks.

0 Kudos
Highlighted
Contributor
Contributor

Hi ,

The client integration plugin works fine on IE 11 in Windows server 2008 R2 for V sphere 6 as well.Just had to add the Vcenter server FQDN to the Local Internet site.Thanks

VitaliY for your help on this Smiley Happy

0 Kudos
Highlighted
Contributor
Contributor

Client Integration Plugin working fine on IE 11 on Windows server 2008 R2 .Just had to add the FQDN of Vcenter server to the Local Zone in IE settings .

Highlighted
Enthusiast
Enthusiast

I had the FQDN in my trusted sites.  Changed it to local intranet, and now it works.  Thanks!

This is on Server 2012 R2.

0 Kudos
Highlighted
Contributor
Contributor

[In reply to message 5 by h3x40rb1t about using IE 11 "Enterprise Mode"]

Thanks -- very helpful.

I'm not on Windows 8.1, I'm on 2008 R2 (i.e. Windows 7, roughly) and using ye very olde vSphere Web Client Integration Plug-in 5.1.0 (don't ask), which by default definitely doesn't like IE 11, but Enterprise Mode worked wonders:  not only does "Use Windows session authentication" now work but, more importantly, virtual-machine consoles now work.

In my case I just edited the local group policy for the machine and, in the administrative template for IE, enabled the setting that lets me toggle Enterprise Mode from IE's Tools menu.  (Perhaps this will get overwritten by our domain group policy;  time will tell).

0 Kudos
Highlighted
Contributor
Contributor

Hi There,

I have tried all the suggestions posted here or anywhere I could find in google.

Client Integration Plugin 5.6 is still not detected in my system.

I have 2008r2 installed and tried IE11/Firefox/Chrome (several versions)

Please help as it is very frustrating now.

I don't have AD so no FQDN. Using IP Address to access web client.

0 Kudos
Highlighted
Enthusiast
Enthusiast

Thanks for all posts. 

I had been using FireFox, but there is some functionality that is not working/available in FireFox. I spoke with a VMware engineer at a VMUG and he stated to use either Chrome preferably or IE11. Company policy doesn’t allow Chrome.

I started receiving this message after running Windows Updates on 10 Enterprise when opening IE11. I had been using IE11 for weeks without issue.

I added the FQDN to the Local Intranet zone in IE11, but was still receiving the message.

On this Discussion, I followed ericmowatt and BKNZC’s suggestions with these changes.

Uninstalled the Client Integration tools from Program and Features

Browsed to the VMware folder and removed all residuals from the Client Integration tools installation. Be sure to check the parent folder before uninstalling to be sure you don’t delete other VMware software installation files.

Restarted the pc.

Right clicked the installer and ran as admin. Originally I had saved the Client Integration tools installer versus running it.

Right clicked IE11 and ran as admin. Then checked to be sure the FQDN was still in Local Intranet zone.

Went to the vCenter server URL and logged in. All functionality is there.

I had used FireFox again since it’s my browser of choice to do some quick tasks in vCenter. The next time I used IE11 I received the above message again. So, I went back through the steps again and now IE11 is working without the message and all functionality is back.

It appears in my case, IE11 and FireFox have an issue. I still use FireFox most of the time and IE11 has not had any issues with vCenter since I’ve not accessed vCenter with FireFox.

vCenter Server 6.0 U2 on server 2012 R2 ver 6.3.9600  

vSphere 6.0 U2

IE11 11.321.14393.0 on Windows 10 Enterprise ver 10.0.14393

FireFox ESR 45.4.0

0 Kudos